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EnerVista Viewpoint Monitoring

Chapter 1: Introduction

Introduction

This Instruction Manual outlines how to use EnerVistaTM Viewpoint MonitoringTM 
software. 

This chapter outlines the following:
• Safety information
• Quickstart 
• Technical support contacts
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Safety symbols and definitions
Before attempting to install or use any device, review all safety indicators in its manual 
and in this document to help prevent injury, equipment damage, or downtime.
The following safety and equipment symbols are used in this document.

Indicates a hazardous situation which, if not avoided, will result in death or 
serious injury.

Indicates a hazardous situation which, if not avoided, could result in death or 
serious injury.

Indicates a hazardous situation which, if not avoided, could result in minor or 
moderate injury.

Indicates practices not related to personal injury.
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Quickstart
EnerVista Viewpoint Monitoring is powerful data monitoring and recording software 
that provides an overall, integrated view of an electrical system. It collects critical real-
time and historical disturbance data to assist with analyzing past and impending power 
system events. It is flexible, high-performance software with high-quality graphics and 
features to maximize productivity and minimize downtime and energy cost.
This section outlines how to install and set up Viewpoint Monitoring.

Features
Viewpoint Monitoring has the following features that make the system powerful and 
easy to use:
• Pre-configured memory maps of GE Vernova Grid Solutions devices
• Drag-and-drop construction of single-line monitoring screens
• Monitors up to 1,000 devices and up to 65,000 data points, depending on license, 

with visual and audio alarm capabilities
• Automatic collection of events and waveforms from GE Vernova Grid Automation 

devices
• Support for communications via Modbus RTU and Ethernet TCP/IP for easy 

communication setup
• Ability to create a historical archive of monitored data for multiple devices, using 

trend reports

Devices supported
The latest list of devices supported by EnerVista Viewpoint Monitoring is described on 
the EnerVista Viewpoint Monitoring website under the Specifications tab and in the 
Release Notes (also available on the website).
Note that the following products do not authenticate login attempts from EnerVista 
Viewpoint Monitoring to execute commands from One-Line screens. Events and 
waveforms also are not retrieved.
• 8 Series relay with Advanced Communication order code
• Universal Relay (UR) with CyberSentry order code

Installation overview
The process is as follows:
• Check the computer requirements
• Check the Microsoft SQL Server name
• Install the software
• Launch the software
• Enter the activation code
• Change default user accounts (passwords and email; optional)
• Add a device
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Check computer requirements
EnerVista Viewpoint Monitoring is optimized for the Microsoft Windows operating 
system. A dedicated computer is required to run EnerVista Viewpoint Monitoring for 
optimal performance and data integrity.
This section describes the system requirements for EnerVista Viewpoint Monitoring 
installation.

Operating system
EnerVista Viewpoint Monitoring supports the following operating systems:
• Windows® 11 64 bit
• Windows® 10 64 bit
• Windows® Server 2022
• Windows® Server 2019
Windows Server 2022 or 2019 is required to use the Windows Remote Desktop 
Services to provide remote access (e.g. for remote viewing, remote troubleshooting).

Databases
EnerVista Viewpoint Monitoring requires a Microsoft SQL Server 2019/2022 Express 
or SQL Server 2019/2022 database to store events, reports, and other data.
Microsoft SQL Server 2019/2022 Express installs with Viewpoint Monitoring if SQL 
Server 2019/2022 Express or SQL Server 2019/2022 is not already installed on the 
workstation.

Hardware requirements
Recommended workstation:
• Intel® Core™ i3 CPU or higher
• 4 GB RAM (minimum)
• Speakers (to support audible alarms)
The following items are recommended:
• Additional hard disk space for increased storage of log and trend data
• Uninterruptible power supply (UPS)
• 17-inch or larger monitor

Check Microsoft SQL Server name
Viewpoint Monitoring uses a Microsoft SQL Server 2019/2022 Express database for 
storage and installs it with the right names when not already installed. Setup names 
are as follows:
SQL Server name — PMCSSQLSERVER12
Database name — EVENTLOGGERSQL
Location of database — C:\ProgramData\EnerVista\EnerVista Integrator\Database
If you already have SQL Server installed, check the name.
To check the SQL Server name:

1. Click Start > All Programs > Microsoft SQL Server 2019/2022 > Configuration 
Tools > SQL Server Configuration Manager. Allow access at the prompt. The 
window opens; if not, due to permissions, ask your computer administrator to log 
in.
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2. Select SQL Server Services in the left pane.
3. Look in the right pane for all SQL Server instances. If your instance is named 

differently, for example SQLEXPRESS instead of PMCSSQLSERVER12, log in to 
the computer as administrator, change the DB_CMD.CMD script located in the 
C:\ProgramData\EnerVista\EnerVista Integrator\Database folder, and run the 
script. You need to be logged in as computer administrator to replace the script 
file.

Figure 1: SQL Server installed

Install software
A license is required for the full installation of EnerVista Viewpoint Monitoring on a 
single workstation. If multiple installations are required, a license will be required for 
each computer.
This section outlines how to install version EnerVista Viewpoint Monitoring. If you 
cancel the installation at any time, you may be required to contact GE Vernova 
technical support in order to prepare the system for a successful installation.

Upgrade support
Viewpoint Monitoring automatically installs and upgrades over any previous 
installations of Viewpoint Monitoring. Existing settings/configurations are supported.
To view changes to the product, see the Release Notes, for example under Start > All 
Programs > EnerVista > Monitoring Release Notes after upgrading.

Installation
A trial version (and installation package) of EnerVista Viewpoint Monitoring is available 
for download from product website and can be unlocked with purchase. The 
installation package includes several files, including the Viewpoint Monitoring software 
installation, Microsoft SQL Server 2019 Express, and .NET framework. 
To install Viewpoint Monitoring software:

1. Download the software from the GE Vernova website.
2. Close any open applications, including Viewpoint Monitoring and its watchdog 

icon in the Windows system tray on the taskbar.
3. Locate the .exe file (for example VPMon815ServerSetup.exe) and double-click it. 

If an error displays about Integrator, the program is located in C:\Program 
Files\EnerVista\EnerVista Integrator.

4. When prompted, allow the program to make changes to the computer.
5. The installation wizard launches. Complete it, allowing installation of all 

recommended programs, such as the SQL Server database. Installation, starting 
with SQL Server, takes from two to 20 minutes. 
The software installs Viewpoint Monitoring and Microsoft SQL Server entries into 
the Start menu, as well as a desktop shortcut for Viewpoint Monitoring. 
Restart the computer at the prompt.
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Figure 2: Installation Wizard

The Viewpoint Monitoring software installation is completed but requires activation.  
The software needs to be launched as an Administrator.

Launch software
1. To run the Viewpoint Monitoring software as an Administrator, before launching 

the software, right-click its icon on the desktop and select Properties. The 
window opens.

2. In the Compatibility tab, enable the check box to Run this program as an 
administrator. Click the OK button to save and exit. This setting remains set 
each time that you launch the software; the prompt to allow the program to make 
changes to the computer appears each time.

Figure 3: Run Software as Administrator

3. Launch Viewpoint Monitoring by clicking its desktop icon. With first launch, it takes 
up to a minute to verify the database.

4. When prompted, allow the program to make changes to the computer.
5. If you launch the software and it stalls at “Verifying Viewpoint Database” it means 

that there is an issue connecting to the database. Click this window and end the 
process, then restart the computer, and/or run the program as administrator as 
outlined. If that does not work, use the following information.
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Figure 4: Launching the software

To troubleshoot, as administrator, verify that SQL Server service 
PMCSSQLSERVER12 exists and is started or running, as follows. In Windows, click 
Start > All Programs > Accessories > System Tools > System Information. 
Access Software Environment > Services.

Figure 5: Verifying that the database is running

If your computer already had Microsoft SQL Server 2019 Express installed before the 
Viewpoint Monitoring installation, the EVENTLOGGERSQL database can fail to attach 
properly. Use the database installation script DB_CMD.CMD, located in the 
C:\ProgramData\EnerVista\EnerVista Integrator\Database folder. 
If your SQL Server instance is named differently, for example SQLEXPRESS instead 
of PMCSSQLSERVER12, change the DB_CMD.CMD script accordingly, and run the 
script. To discover the name of the SQL Server instance go to Start > All Programs > 
Microsoft SQL Server 2019 > Configuration Tools > SQL Server Configuration 
Manager. Select SQL Server Services in the left pane. In the right pane are all SQL 
Server instances. In the example shown, there is only one instance, 
PMCSSQLSERVER12, which is correct.

Figure 6: Checking the database name
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If you need to check the DB_CMD.CMD script installed by Viewpoint Monitoring, it is 
located in the C:\Program Files(x86)\Enervista\EnerVista Viewpoint Monitoring\ folder.
If you changed the script to attach EVENTLOGGERSQL database to a different SQL 
Server instance, you need to change ODBC settings. Open the ODBC Data Source 
Administration wizard by double-clicking the C:\Windows\System32\odbcad32.exe file 
(on Windows 32 system) or C:\Windows\SysWOW64\odbcad32.exe (on Windows 64 
system). Click the System DSN tab. Select the PMCS65 entry and click the 
Configure button. In the window that opens, verify the name of the SQL Server. The 
name needs to be the same as in the DB_CMD.CMD file. Click the Next button and 
continue in the wizard.

Figure 7: Checking the server name

If the configuration is incorrect, a “Connection failed” message displays. Click the 
Back button in the wizard and verify your settings.

Figure 8: Incorrect configuration message

6. With successful launch of the Viewpoint Monitoring software, if GE Vernova 
supported devices are detected, a window displays providing the opportunity to 
import configuration for them. Select any supported devices, and click the Import 
button to do so. Otherwise, click the Cancel button to exit from the window.
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Figure 9: Importing a UR family device

7. With successful launch, the main EnerVista Viewpoint Monitoring window 
displays. By default the software is in trial mode, which limits software use to 90 
days and 50 devices (after 90 days, access is restricted to 1 device and 1000 
tags). For a purchased version, unlock the software by entering the activation 
code (next section).

Figure 10: Main window

Enter activation code
A software license activation code allows for the installation of EnerVista Viewpoint 
Monitoring on one computer. Use the following procedure to generate a license 
activation code, and enter it into the software to activate.
With the “OPC Option,” Viewpoint Monitoring can send data that is being read from the 
relays and meters to any third-party system compliant with the Object Linking and 
Embedding (OLE) for Process Control (OPC) standard. If your license code has this 
option, the unlock operation needs to be done with Viewpoint Monitoring run as 
administrator, as outlined earlier (right-click, Properties > Compatibility > Run this 
program as an administrator).
When updating the license, if the application is unlocked and you upgrade to a larger 
number of devices or add the “OPC option”, first do a license transfer (for example, 
use Site ID of 94AB083B) as outlined in the Instruction Manual. This removes the 
previous license, restarts the program, and you enter the new license code.
To unlock an installation:

1. In the main window of Viewpoint Monitoring, click Help > License Management. 
The window opens.
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Figure 11: License manager window

2. Note the Site ID and Machine ID, and leave the window open.
3. Generate an activation code as follows. 

Log in to https://apps-ex.gs.ec.ge.com/swmgr/ using the Order # and Password 
provided with the software or sent by email from GE Vernova. 
Enter the Site ID and Machine ID, and generate the activation code. Record the 
number.

Figure 12: Log in to generate the activation code

4. In Viewpoint Monitoring, enter the code in the Activation Code field, and click the 
Unlock button. This unlocks Viewpoint Monitoring. The software is ready to use.
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Change default user accounts
Two user accounts (Administrator, Guest) and three user groups are created by default. 
Permissions are set at individual and group levels.

Table 1: Default user accounts

After installation, optionally change the passwords and set the email addresses for the 
default accounts.
To change passwords and email addresses for user accounts:

1. Click Tools > Administration and select an option.
Further information is given in the Administration chapter of this manual.

Add a device
The latest list of devices supported by EnerVista Viewpoint Monitoring is described on the 
EnerVista Viewpoint Monitoring website under the Specifications tab and in the Release 
Notes (also available on the website).
Depending on the device count of the license (50, 100, 300, 500, or 1000) the number of 
devices can be added and configured in Viewpoint Monitoring.
Note that the trial version is restricted to 50 devices and runs for 90 days from installation. 
After 90 days, Viewpoint Monitoring access is restricted to 1 device or 1000 tags (data 
points). 
The trial device configuration is exported to: 
C:\Users\Public\Documents\EnerVista\Viewpoint Monitoring\VPMConfigBackup\folder
There are 3 ways to add devices in Viewpoint Monitoring: 

1. By import of GE Vernova devices 
2. By GE Vernova device setup 
3. By creating custom files for third-party devices 
The recommended approach for GE devices is by automatic import followed by GE device 
setup if required.
Third-party, non-GE Vernova devices should use method 3 - By creating custom files for 
third-party devices to add the device.
For a non-GE Vernova device and with .cdd file created in the Custom Device Editor the 
third procedure (creating custom files for third-party devices) is used to add the device. 
Search the applicable computer for the .cdd file. 
Such a file is created automatically for GE devices, for example, so there can be such a file 
on the computer. 
The approach is as follows using BASSY_100.cdd as a file name and BASSY as the device 
name.
Locate the BASSY_100.cdd file, add it to the computer to prepare the server-side, then in 
the Viewpoint Monitoring software when adding a device, select Others for the Device 
Type, enter the BASSY name in the Order Code field, and click the Test Communication 
button.
To add a device by import:

1. Click File > Import Devices > Perform Search. 
Or if you have a .env or .ds file of the device to add, click File > Import Devices > 

User account Default 
password

Group Permissions

Administrator password Administrato
r

Manage and edit accounts; full control in 
one-line, annunciator, trending reports

Guest password Guest View-only access to one-line, annunciator, 
trending reports
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Specify Location.
To add a third-party device:

1. Create a profile for it under File > Custom File Editor. 
The best way to determine if the device is a third-party device is to look in the 
Device Type drop-down list outlined in the next procedure. Further information on 
completing the fields is given later in this manual.

To add a device using device setup:

1. In the main Viewpoint Monitoring window, click the Device Setup button. The 
window opens.

2. To add devices automatically within the computer subnetwork, try clicking the 
Discover URs button. For example, if the computer IP address is 10.15. 21.70, 
the software checks for devices on 10.15.21. A message displays when none are 
found. If none are discovered, continue with the rest of this procedure.

3. Click the Ethernet or Serial option to reflect the interface over which the 
computer is to communicate with the device, then click the Add Device button. 
The fields will populate on the right side with the device information. 
Note: Modem connections are not supported.

4. Change the Device Name, for example to N60_v72 or London_UR_B30. Note 
that device names can be listed alphabetically by checking the sort devices box 
(lower left).

5. For Ethernet, enter the IP Address, Slave Address, and Modbus Port number. 
For a GE Universal Relay (UR) series device, the information on the screen looks 
similar to the following.

Figure 13: Adding a UR device (Ethernet interface)

For serial, the window looks similar to the following. Complete the Slave Address to Stop 
Bits fields.
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Figure 14: Adding a device with a serial interface

6. From the Device Type drop-down list, select the device. The list is the same for 
Ethernet and serial interfaces. Select Others for non-GE devices, for example for 
which you have a .cdd file.

7. For Ethernet, the File Retrieval Protocol specifies the protocol to use to retrieve 
waveforms and events from the device. The trivial file transfer protocol (TFTP) 
and Modbus are supported for UR and 8 Series devices. The field becomes active 
with the Device Type selection. If in doubt about whether to choose TFTP or 
Modbus, then select TFTP, which is commonly used for those devices.

8. For some GE Vernova devices (UR, URPlus, 850, 369, 750, and so on), the Read 
Order Code button is active. Click it. The system populates the Order Code and 
Version fields.
For all other devices, enter the order code; for a device for which you created the 
.cdd file simply enter the name for the device. An example of behavior when 
completing this field is that the order code populates as EPM 9900P when the 
EPM 9900P is selected as the Device Type. The following table shows examples.

Table 2: Example order codes for other devices
Device Order code

Multilin DGCM Field RTU DGCM
Enhanced Micro Versa Trip C EMVTC
Enhanced Micro Versa Trip D EMVTD
EntelliGuard Low-Voltage 
Switchgear

ELVS

EntelliGuard Trip Unit GTU
EPM 2200 EPM2200
EPM 4600S EPM4600S
EPM 4600T EPM4600T
EPM 6000 EPM6000
EPM 6000T EPM6000T
EPM 6010 EPM6010
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After completing the Order Code field, click on the Test Communication button. 
The system tests communication access to the device and populates the Version 
field. 
A square green LED indicator displays beside the button indicating successful 
communication.

Figure 15: Successful communication with device

9. Optionally enable any of the options displayed, which are active when supported 
by the device and which vary by device. If in doubt, enable all options.

10. Plug and Play Enabled — Displays the device in the Viewpoint Monitoring IED 
Dashboard, providing convenient access to the device, including the front panel to 
enter commands. Also provides a predefined, device-specific, set of online 
diagrams that allow an instant view of critical information.

11. Waveform — Monitors the device and downloads automatically the new 
waveform generated by the device.

12. Events — Downloads automatically and stores to the database the event records 
from the device.

13. Time Download Enabled — Synchronizes the real-time clock of the device with 
the computer clock; synchronization is done every 12 hours. Do not enable this 
option if the relay is write-protected or the password for commands is set on the 
relay.
PMU Records — Display Phasor Measurement Unit (PMU) records.

14. Click the OK button to save the configuration and exit. Viewpoint Monitoring is 
now configured to work with the device.

EnerVista Viewpoint Monitoring is now installed and configured for general use. To launch 
the application, click Start > All Programs > EnerVista > Viewpoint Monitoring or click 
its desktop icon. Continue with the EnerVista Viewpoint Monitoring Instruction Manual, 
launched by pressing the F1 key in the software.

EPM 6100 EPM6100
EPM 7000 EPM7000
EPM 7000P EPM7000P
EPM 7000PT EPM7000PT
EPM 7100 EPM7100
EPM 9700 EPM9700
EPM 9900P EPM9900P
FIRETRACER FIRETRACER
MET MET
MRPO MRPO
MultiLink ML2400 ML2400
MultiNet MN1000 MN1000
PLEPM PLEPM
Spectra Micro Versa Trip MVT
UPS LAN PRO UPSLP
UPS SG UPSSG
VERSAMAX VERSAMAX

Device Order code
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The software supports an English keyboard only. Adding other languages in Windows 
under Control Panel > Region and Language > Keyboards and Languages can render 
the software unresponsive, for example when using the Formula Editor.

Add remote viewing computers - ViewNodes
The option exists to install remote viewer capability on other computers. This means that 
other computers can access output, reports, waveforms, event records and other output 
from Viewpoint Monitoring. The remote computer and function is referred to as a 
ViewNode. Instructions to install the ViewNode software and add remote computers are 
provided in the Instruction Manual.

Uninstall software
To uninstall the Viewpoint Monitoring software:

1. If you have ViewNode support running for remote computer access, stop it in 
Viewpoint Monitoring by clicking File > ViewNode Management > Remove 
ViewNode Support. The option is active when support is present and inactive 
when no support is present. When service stops, all remote computers lose 
access.

2. Close the software.
3. Click Start > Control Panel, then Programs and Features.
4. Click EnerVista Viewpoint Monitoring or Viewpoint Monitoring. If the item 

does not display, uninstall it using the .exe installation file.
5. Click Uninstall and confirm the deletion. The software uninstalls.
To uninstall the SQL Server database that was installed/used by Viewpoint Monitoring, 
follow a similar approach. Do not uninstall these applications when used by other software.
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For further assistance
For current manuals and software go to:

Website: https://www.gevernova.com/grid-solutions

For product support, contact the information and call center as follows:
GE Vernova
650 Markland Street
Markham, Ontario
Canada L6C 0M1
Worldwide telephone: +1 905 927 7070
Europe/Middle East/Africa telephone: +34 94 485 88 54
North America toll-free: 1 800 547 8629
Fax: +1 905 927 5098
Worldwide e-mail: multilin.tech@gevernova.com
Europe e-mail: multilin.tech.euro@gevernova.com
Website: https://www.gevernova.com/grid-solutions
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EnerVista Viewpoint Monitoring

Chapter 2: Product description

Product description

This chapter outlines the following:
• New features and supported products
• Viewpoint Monitoring
• Demonstration files
• Trial version
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Introduction
EnerVista Viewpoint Monitoring is software for on-demand monitoring and control of 
electrical equipment. It uses Microsoft SQL Server or SQL Server Express as its 
database.
Viewpoint Monitoring comes with the following features that make the system powerful 
and easy to use:
• Pre-configured memory maps of GE Grid Solutions devices
• Drag-and-drop construction of single-line monitoring screens
• Monitors up to 1,000 devices and up to 65,000 data points, depending on license, 

with visual and audio alarm capabilities
• Automatic collection of events and waveforms from GE devices
• Built-in Modbus remote terminal unit (RTU) network compatibility for an open 

network architecture and high-speed communication
• Built-in Ethernet TCP/IP network compatibility for high-speed communication and 

reduced wiring costs
• Ability to create a historical archive of monitored data for multiple devices using 

trend reports

New features and supported products
See the current release notes for a complete list of new features and supported 
products.
For example look under Start > All Programs > EnerVista > Monitoring Release 
Notes after upgrading.
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Features
The features of Viewpoint Monitoring include the following:

Add devices
Viewpoint Monitoring can communicate with devices that use Modbus protocol for 
accessing data. In addition to easy, predefined GE Vernova device setup and import of 
setup files, the Custom File Editor allows you to define a new device to be used within 
Viewpoint Monitoring as well as edit and delete devices already defined. The polling/
scan interval is every second to retrieve actual values from devices.

View remotely on multiple computers
Viewpoint Monitoring is installed on a workstation retrieve and visualize data from 
supported and configured devices. 
In addition, two options exist to access the Viewpoint Monitoring instance remotely: 
Windows Server Remote Desktop Services (RDS) Connection through Windows 
Server option installation or through Viewpoint Monitoring ViewNode client software 
installed on a remote workstation.

Scalable licensing
Depending on the license, 50, 100, 300, 500, or 1000 devices can be configured in the 
software. When using the trial version, the number of devices is limited to 50. The 
licensing is summarized as follows:
• 50 devices and 3,000 data points
• 100 devices and 5,000 data points
• 300 devices and 30,000 data points
• 500 devices and 65,000 data points
• 1,000 devices and 20,000 data points
Licenses can be upgraded to add capacity.

OPC data access
Viewpoint Monitoring provides the optional OPC option - Object Linking and 
Embedding (OLE) for Process Control (OPC) selected at time of purchase or a later 
upgrade. With the OPC, Viewpoint Monitoring the data collected from connected 
devices (GE Vernova and configured devices) can be accessed by third-party OPC 
compliant automation or monitoring system through OPC requests to Viewpoint 
Monitoring. 
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Functions
This section explains each component that displays in the main window of Viewpoint 
Monitoring. In addition, there are menu functions, such as password management, 
support for adding third-party devices, and template importing.
The general approach to using Viewpoint Monitoring is as follows:
• Add device
• Configure a diagram in the One-Line Editor
• View the data in the One-Line Viewer
• Set alarms in the Annunciator
• Monitor device operation in the IED Dashboard and/or the Annunciator

Figure 16: Part of the Viewpoint Monitoring main window

IED Dashboard
When the "Plug And Play" option is enabled for a device, the device displays in the 
IED Dashboard. The device can be controlled from the dashboard using a virtual view 
of its front panel. There is access to a set of device-specific online diagrams that offer 
a quick view of the most critical information for that device type.

Figure 17: IED Dashboard
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Device Setup
The Device Setup function is used to identify devices for use in Viewpoint Monitoring. 
The information is added automatically, by import, or manually.

Figure 18: Name and Viewpoint Monitoring options for a device

One-Line Editor and Viewer
The One-Line Editor is used to draw diagrams for equipment monitoring and control. It 
is used to create interactive one-line diagrams that are connected to devices to 
monitor and understand remote site configuration as well as view readings and status 
updates.
The One-Line Viewer then displays the data from the equipment.
The figure shows an example for monitoring motor status.

Figure 19: Diagram created to monitor motor status

Annunciator
This function allows alarms and alerts to be set and managed.
The Annunciator actively monitors measured values and generates alarms. Alarms 
can be configured for activation whenever a digital status changes state or whenever 
analog values change beyond a threshold.
The Annunciator provides visual, audio, and email notifications.
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Figure 20: Example of Annunciator alarms

Events
As enabled per-device, the event records from devices are downloaded automatically 
and stored in the database, creating a system-wide sequence of records. Viewpoint 
Monitoring continuously polls the device to see if any events have been detected, 
downloads the event records, and stores them. They are viewable in Viewpoint 
Monitoring.

Figure 21: Event records

Trending Reports
Trending reports are used to archive monitored data for multiple devices. The trending 
reports record the values of monitored analog and digital points, with one-minute 
resolution. The data stored in the reports are viewable as graphs and tables. The data 
is stored in the database.

Figure 22: Example of chart
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Waveforms
Waveform (oscillography) files from GE Vernova Grid Automation supported devices 
are downloaded automatically from each device and stored on the computer hard 
drive. When a new waveform is detected, the file is downloaded to the hard drive.
Support for COMTRADE files means that they are viewable in Viewpoint Monitoring. 
The COMTRADE viewer feature within Viewpoint Monitoring provides a visual display 
of power systems data and relay operation data captured during a specific triggered 
event.

Figure 23: Part of a waveform file

Administration
Administration is performed in several windows in Viewpoint Monitoring. These 
functions include preferences, passwords, users, groups, and remote computer 
access.

Figure 24: User account management
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Demonstration files
Viewpoint Monitoring includes several demonstration files. They are contained in the 
following folder and are accessed within Viewpoint Monitoring:
C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents\Examples\
Other EnerVista installations can have similar files, for example
C:\Program Files (x86)\GE Power Management\URPC\Data\Demo\
The following file extensions are used:

As documented later, these and other files can be imported into the software and 
customized for use.
To view a demonstration file:

1. In the Control Panel for Windows, change the Folder Options so that hidden files and 
folders show.

2. In the main Viewpoint Monitoring window, click File > Open and open the following 
file, which is a one-line diagram used as an example:

C:\ProgramData\EnerVista\Viewpoint Monitoring\My 
Documents\Examples\SUBSTATION3.SF

3. When done, turn off hidden files and folders.

Figure 25: Viewing a one-line demonstration file of a substation

.cfg Waveform diagram

.sf One-line diagram

.ap Annunciator alarm setup

.rep Report file
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Trial version
Both Viewpoint Monitoring and Viewpoint ViewNodes (for optional remote access) 
install by default in trial mode to allow users to experience and use the software for a 
limited time period and functionality. 
A license is required to be purchased for full functionality.
The latest version of Viewpoint Monitoring or Viewpoint ViewNodes can be 
downloaded from: https://www.gevernova.com/grid-solutions

The trial version functions as follows:

Viewpoint Monitoring
• Limited to 50 devices
• Trial runs for 90 days from installation
• After 90 days, Viewpoint Monitoring access is restricted to 1 device and 1000 

tags. 
The trial device configuration is exported to: 
C:\Users\Public\Documents\EnerVista\Viewpoint Monitoring\VPMConfigBackup\f
older

You unlock the software by entering the activation code as outlined in the Quickstart 
section of this manual.

Viewpoint ViewNodes (remote access)
• Use of ViewNode remote access for 15 days
Unlock the software by entering the activation code as outlined in the Quickstart 
section of this manual.
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EnerVista Viewpoint Monitoring

Chapter 3: Interface

Interface

This chapter explains the software interface, preferences, communication status 
indicator, schema indicator, and formula editor. It explains the main Viewpoint 
Monitoring interface. Toolbars and buttons for individual windows are explained in the 
relevant chapters.
There are no “must configure” settings outlined in this chapter. If you are first getting 
started with Viewpoint Monitoring, consider adding passwords and user accounts as 
outlined in the Administration chapter, then skim this chapter to view the features 
available.
This chapter outlines the following:
• Main window
• Full screen mode
• Preferences
• Communication status
• Alarm indicators
• Formula editor
• Online help
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Main window
Upon launch of Viewpoint Monitoring, the default view is the main window. This default 
can be changed, as outlined in this chapter.

Figure 26: Viewpoint Monitoring main window

Login (top right) — Active when authentication is required, as set in the preferences. 
Does nothing when inactive.
IED Dashboard — View and manage devices added.
Device Setup — Add and configure your devices and their components.
One-Line Editor — Create interactive one-line diagrams using graphical tools. These 
diagrams are called schema.
One-Line Viewer — View one-line diagrams.
Annunciator — View and monitor alarms and alerts.
Events — View event records for devices.
Trending Reports — View and create data/report diagrams.
Waveforms — Tools and viewer for COMTRADE-formatted waveform files.
Administration — Add/edit/delete groups and users who can access the system, set 
passwords.
To return to the main window:

1. Double-click the computer icon at the top left of the window, click File > Close, or 
click the X at the top-right of the window.
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Full screen mode
Full screen mode increases the viewable area for viewing one-line diagrams, 
annunciator panels, and COMTRADE oscillography files.
It can be activated separately (outlined here) or set as a default (outlined later for the 
Startup Screen).
To access Full Screen mode:

1. Click View > Full Screen. The display fills the entire monitor view.

Figure 27: Accessing Full Screen mode

To return the screen to original view:

1. Click the Close FullScreen icon, press the Esc key, or mouse-over the hidden 
menu at the top and select the View > Full Screen option.

Figure 28: Close FullScreen icon to exit Full Screen mode

Figure 29: Mouse-over hidden menu to exit Full Screen mode



30 ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL

PREFERENCES CHAPTER 3: INTERFACE

Preferences
Although the software is fully functional using the default values, these defaults can be 
configured.
To access preferences:

1. Click File > Preferences.
Each of the tabs is outlined in this section.

Keyboard language
The software supports an English keyboard only. Adding other languages in Windows 
under Control Panel > Region and Language > Keyboards and Languages can 
render the software unresponsive, for example when using the Formula Editor.

Security
The following security settings can be configured in the File > Preferences > Security 
tab. These settings over-ride individual user account settings. For example, if the tab 
is used to specify that users do not log in to Viewpoint Monitoring, then users do not 
log in even when the user accounts have passwords assigned to them.
None — Users are not required to log in. Default.
FULL — Users must log in at software startup.
Enhanced — Users receive guest privileges at startup, without login. Access is 
granted to the IED Dashboard, Waveforms, and viewing in One-Line Viewer, 
Annunciator, Events, and Trending Reports. The user does not have access to Device 
Setup, One-Line Editor, and Administrator functions. The user can log in to receive 
additional permissions assigned to their user account, such as full access to the One-
Line Editor or Annunciator.
Regardless of login/security mode set, by default all users must hold down the CTRL 
key when entering a command. This feature is configured in the Control tab, outlined 
later.
For any change to take effect, the software needs to be closed and re-opened. If the 
Watchdog setting is on in its tab, you also need to either turn it off first or completely 
exit from the software in the system tray.
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Figure 30: Security tab

Startup screen
The main window displays by default with launch of Viewpoint Monitoring. The 
following windows can be selected under the File > Preferences > Startup Screen 
tab to display upon launch:
• Main window
• IED Dashboard
• Specific schema, such as an alert
• Specific Annunciator panel
• Full screen mode or normal

Figure 31: Default for startup

Up to 10 files can be opened automatically upon start of Viewpoint Monitoring.
To select files to open upon startup:

1. Click the ... Browse button and select one or multiple files.
Multiple files are stored with full paths, delimited by ;
There is a limitation of 1024 characters for the total of this composed path.
An example of a path is
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C:\Documents and Settings\All Users\Application Data\EnerVista\Viewpoint 
Monitoring\My Documents\PROVIDENCE.SF;C:\Documents and Settings\All 
Users\Application Data\EnerVista\Viewpoint Monitoring\My 
Documents\SUBSTATION3.SF
In the example shown, two one-line files are selected.

Figure 32: Selecting files to open upon startup

Audible alarms
Sounds serve to alert when an LED state changes in one of the opened schemas in 
the One-Line Viewer. The default sounds can be changed to any .wav files. When 
more than one opened schema has a condition to play a sound, the sound file for the 
LED type with highest priority plays.
The sounds are enabled by default without any sound files specified. Sound files in the 
.wav formats are included with Viewpoint Monitoring for use. The default folder is 
C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents\Sounds
The following sounds can be set in the File > Preferences > Audible Alarms tab.
Alarm — Sounds when an LED changes to an Alarm condition.
Alert — Sounds when an LED changes to an Alert condition.
Reset — Sounds when LED changes state back to Normal after being Acknowledged 
and Reset.
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Figure 33: Setting the sound file for alarms

To stop the sound:

1. Click the Acknowledge button when viewing the schema containing the active 
condition.

Annunciator
Use the File > Preferences > Annunciator tab to send email notifications from the 
Annunciator panel. You enter the Simple Mail Transfer Protocol (SMTP) mail server 
address in the space provided.
To configure email notification:

1. Access the Watchdog tab and enable the watchdog function.
2. In the Annunciator tab, configure the window.

SMTP Mail Server — Address of the email server. Examples are 
mail.yourcompany.com and smtp.yourcompany.com.au. The address can be 
viewed in Microsoft Outlook under File > Info > Account Settings > Account 
Settings > E-mail in Windows 7, for example, or consult your information 
technology (IT) department, to ensure that the mail server is configured to accept 
SMTP mail requests, and that a user name and a password are not required when 
sending messages.
Messages sent from the Annunciator Panel originate from — Enter a valid 
email address that is recognized by the SMTP mail server. Otherwise email 
cannot be sent by the mail server. An example is to use the email address of the 
employee who is the main Viewpoint Monitoring administrator or to create an 
email account specifically for Viewpoint Monitoring.
Message Format:
– Standard Format — The email message contains several lines of 

information:
Name — Indicator's display name
Device — Device name
Report Type — Parameter name = Value

– Short Format — This is a single line that can be used for texting to a mobile 
phone:
time
indicator's display name
device name
report type
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parameter
value

Files for Alarm Continuous Run — Set a maximum of five alarm files. Viewpoint 
Monitoring opens these files upon startup and keeps them running continuously. If 
you close an Annunciator panel file that is in the list of files to continuously run, 
Viewpoint Monitoring automatically opens it again.
Click the Add button to add any files.
In order to select the Annunciator panel files to run continuously, enable the 
Viewpoint Monitoring watchdog in the Watchdog tab. The watchdog is a Windows 
service to ensure Viewpoint Monitoring runs continuously.
After clicking the Ok button to activate the function, any alarms display 
automatically in the EnerVista Viewpoint software, in multiple tabs when multiple 
files have been added. For email to be sent, the alarm needs to be configured as 
such in the Annunciator window.

Figure 34: Configuring alarm notification defaults
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Waveform and events
Waveform and event information, plus time synchronization, can be configured for 
continued retrieval from devices after you exit from the Viewpoint Monitoring software. 
Use the File > Preferences > Waveform, Events, Time Download tab.

Figure 35: Retrieve waveforms and events after software shutdown

Event logging
Options for event logging are configured in the File > Preferences > Event Logging 
tab and can include login/logout and alarms and alerts from the one-line diagram and 
annunciator panels. This tab sets defaults for activity within the Viewpoint Monitoring 
software.
Events are accessed using the Events option in the main window.
Devices are configured for event retrieval using the Device Setup option in the main 
window.

Figure 36: Logging of activity within the software
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Control
For security, by default the action of sending a control command to a relay requires the 
user to hold down the CTRL key as they select a button with the mouse pointer. This 
key can be changed to the Shift key or disabled under the File > Preferences > 
Control tab.
Note that the following products do not authenticate login attempts from EnerVista 
Viewpoint Monitoring to execute commands from One-Line screens. Events and 
waveforms also are not retrieved.
• 8 Series relay with Advanced Communication order code
• Universal Relay (UR) with CyberSentry order code
In the following example, the user is in the One-Line Viewer, clicks the purple Clear 
Data Logger button, and is prompted by a window to press the CTRL key to execute 
the command.

Figure 37: Prompt to press the CTRL key for command execution

Figure 38: Default key to press for command entry
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Host information
The File > Preferences > Host Information tab displays the name and IP address of 
the computer on which Viewpoint Monitoring is installed. The default Site Name can 
be changed; it is the user-defined name that a remote ViewNode computer sees when 
connected to the Viewpoint Monitoring server. Examples of user-friendly Site Names 
are "VPM_Server1" and "Viewpoint Monitoring 1."

Figure 39: Computer information and site name

Watchdog
The watchdog service can monitor Viewpoint Monitoring and ensure that the software 
runs continuously. It is disabled by default in the File > Preferences > Watchdog tab. 
Entry of a user name and password can be required to change the setting; use the 
Windows login password, not a Viewpoint Monitoring password.
When the watchdog is enabled, Viewpoint Monitoring does not exit when the user 
exits from the software. Instead, Viewpoint Monitoring minimizes and appears as an 
icon in the System Tray / Notification Area located in the bottom right corner of the 
Windows desktop or hidden as an icon in this area.
To restore Viewpoint Monitoring:

1. Double-click the icon in the System Tray. When hidden on the tray; click the up 
arrow to locate the icon.

To exit Viewpoint Monitoring when the watchdog is set to keep it running:

1. Right-click the icon in the system tray and select Exit.

Figure 40: Viewpoint Monitoring computer icon on System Tray beside clock
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Figure 41: Watchdog set to keep software running

Trending reports and consumption data
Trending reports for a device record the values of monitored analog and digital points, 
with one-minute resolution.
The export consumption function provides a simple way to access energy use 
recorded by devices that support Energy values (URs, EPMs, 8 Series, and so on) 
and collected and stored by EnerVista Viewpoint Monitoring periodically. The data are 
for energy consumption as recorded by the device, not as used by the device. You can 
select one or more devices and one or more energy data values from a predefined list. 
Data is exported in a comma delimited format that can be processed further in 
Microsoft Excel including device name, parameter, units, start date/time, starting 
value, end date/time, ending value, consumption (end value - start value) and a quality 
code.
Trending reports and consumption data are stored in the local database. To prevent 
size-related problems, old records can be purged periodically. The preferences here 
purge records based on the number of days. There are additional purge functions in 
the Trending Reports function; see the Trending Reports chapter.

Configuration
Use the File > Preferences > Trending & Consumption tab to set the following 
purge options.
Perform Automatic Purge — For the SQL Server Express database, automatic 
purge is mandatory, so this option is enabled by default and cannot be disabled. For all 
other editions of the installed SQL Server, users can opt out of automatic purge and do 
maintenance themselves.
Based on configuration maximum days available — For SQL Server Express, the 
maximum is 365 days. For all other SQL Server editions, the maximum is 730 days. 
The maximum is adjusted each time that a parameter is added/deleted. As such, the 
setting is read-only.
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Preferred maximum days — Decreases or increases the maximum days. The 
minimum is 30 days. The maximum is determined by the previous field and the 
parameters added/deleted, for example 365 or 730 days.

Figure 42: Setting number of days for report storage

Configure energy consumption export
To configure energy consumption export:

1. Click Tools > Energy Consumption > Configure. The window opens. If you 
instead see a message to stop all Consumption Reports first, go to Tools > 
Energy Consumption > Status and click the Stop button.

2. Select the device and any functions, such as SRC1, on the left side. The devices 
are automatically listed under Ethernet when they are set up in the network this 
way. You can configure multiple devices for exports.

3. Select the values for which you want to generate an export on the right side. If you 
cannot see fields on the right side to select, select a field on the left side.

4. Click the Ok button to save and exit.
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Figure 43: Energy data available to export

Check device status
To check device status before exporting energy consumption data:

1. Click Tools > Energy Consumption > Status. The window opens.
2. Click the Run button. The indicator initially turns red while the device is checked. 

Wait 45 seconds to one minute for the check to complete.
3. The color of the Status field indicates the state of the device(s).

Grey — No information. Click the Run button.
Red — The device is offline, not functioning properly, or does not support power 
or energy monitoring in its order code. Fix the device before proceeding, for 
example by checking it in the IED Dashboard in Viewpoint Monitoring, then the 
Dashboard and Power buttons to ensure that all sources have energy data. If 
required, configure the device sources.
A device can be online and appear to function normally, only to have no energy 
data available for reading because it does not support such functions in its order 
code. This is indicated by a dash, or -, where data is supposed to appear and can 
be verified by the absence in EnerVista software of Actual Values > Metering > 
Source > Energy.
Green — The device is functioning normally. Energy consumption data can be 
exported.

4. Click the Stop button, else the status continues to be checked, even when the 
window is exited. There is no harm in leaving the status running, in which case it 
continues to fill the database, which is eventually cleared. If left running, you can 
be prompted later when exiting the software to turn off energy consumption data.
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Figure 44: Checking status of two devices

Export energy consumption data
To export energy consumption data:

1. Check device status as outlined in the previous procedure.
2. With the device in good status, click Tools > Energy Consumption > Export. 

The window opens.
3. Select the parameters for the device on the left side, for example the sources.
4. Configure the export on the right side. Options are custom, weekly, and monthly 

data. This refers to the data only and does not set up regular, periodic exports.
Set the file path and name. The default is similar to 
C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents\ Consumption 
Report

Figure 45: Exporting a week of consumption data

5. Click the Ok button to check data availability for time period specified and to 
export the data in the location specified. The file is saved as an Excel 
spreadsheet. Open it. For columns that display #######, expand the column 
width to view data.
Quality — This column reads "Complete" when all the data points are present for 
the specific interval. It reads "Incomplete" when some data points are missing for 
the specific interval, for example because the device was not communicating for 
an interval of time. This column reads "No Data" when the software cannot 
communicate with the device, for example because the device is off.
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Figure 46: Exported data



CHAPTER 3: INTERFACE COMMUNICATION STATUS

ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL 43

Communication status
This status, or LED, indicator displays in Viewpoint Monitoring. It provides visual and/
or audible notification when an undesirable condition occurs. Both a digital state and 
an analog parameter can be attached to an LED state. In addition, existing analog 
parameters have been enhanced to include the option of defining an alarm condition.
The communication status shows one of two states:

To view the communication status:

1. The communication status is located at the top-right of a window when a schema 
is opened in a One-Line Viewer, when using the Annunciator tool, and when in the 
IED Dashboard.

To view additional information about the communication state:

1. Click the Communication Status button. The Device Status window opens. This 
window is explained in the next section.

Figure 47: Device status window

Device status
Clicking the Communication Status button opens the Device Status window. It does 
not open while in the Annunciator panel.
A green status represents a device that Viewpoint Monitoring is successfully 
communicating with. A grey status represents a device that Viewpoint Monitoring 
cannot communicate with. When no status displays, as in the previous figure, it means 
that nothing has been configured in Viewpoint Monitoring for that device, such as a 
One-Line schema.

 All relays on the schema are successfully communicating

 The schema is having communication problems with at least 
one relay
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One Device Status window can be open for each schema drawing (.sf file). When you 
have multiple schema diagrams open, you can have the same number of Device 
Status windows open.
The window displays the Device and Parameters being monitored, the Actual Values, 
and a summary at the bottom of the window. The parameters need to be configured in 
Viewpoint Monitoring, else the window is blank. Any parameters/components that 
have not been assigned to the device are not listed. The actual values are updated 
every few seconds. LED status indicators when using the One-Line Viewer are 
outlined in the LED indicators section on page 127.

Figure 48: Device Status window accessed from One-Line Viewer

The summary at the bottom of the window is explained as follows:
• Online — The number of devices connected properly with any configured 

parameter readings being updated by Viewpoint Monitoring on a real-time basis
• Offline — The number of devices not connected properly. No parameter readings 

are being read by Viewpoint Monitoring. To attempt to reconnect all Parameters of 
a device, right-click the device and select Connect Device.
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Figure 49: Reconnecting to a device

• Invalid — Device/parameter is not configured properly according to current 
schema settings. Open the One-Line Editor and reconfigure the component/
parameters.

When accessing the window within the One-Line Viewer, you can identify the 
parameter components in the schema diagram by double-clicking the item in the 
Device Status window.
To identify a component in a schema diagram using the Device Status window:

1. In the Device Status window accessed in One-Line Viewer, expand the listing for a 
device by clicking the + icon or by double-clicking the device.

2. Double-click a parameter to identify it in the One-Line Viewer window. The 
parameter is highlighted in the One-Line Viewer window.
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Alarm and alert LED indicators
Each opened schema has an associated tab located at the bottom-left of the screen. 
This section explains the status indicators and how to add them.

Figure 50: Schema indicator

Status explained
Each schema tab can have two pieces of information:
• A schema Indicator (round colored LED button)
• The name of the schema
For the tab to display a Schema Indicator, one of two rules must be satisfied as 
follows:
• The schema must contain at least one LED, or
• The schema must contain at least one analog parameter that has at least one 

alarm condition defined

A flashing indicator means that there has been a state change.
The indicator displayed is the one with the highest priority, outlined as follows.

Table 3: Priorities

 There are no LEDs on the schema

 All LEDs are in normal condition

 At least one LED is in alert condition and the operator has acknowledged the 
LED. There are no alarm conditions present.
At least one LED is in alarm condition and the operator has acknowledged the 
LED

(flashing)

At least one LED has been reset. There are no alarms or alerts present.

(flashing)

At least one LED is in alert condition. There are no alarms. At least one LED 
has changed state.

(flashing)

At least one LED is in alarm condition. At least one LED has changed state.

No communication to any of the relays on the schema

 Priority Level 1 - Lowest

Priority Level 2

 Priority Level 3
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Table 4: Digital LED status

Statuses for the One-Line Viewer are outlined in the LED indicators section on page 127.

Alarm vs alert
When any alarm condition is met, the LED indicator changes from green to red. An 
alarm sound, when configured, plays once or continuously.
When any alert condition is met, the LED indicator changes to yellow. An alert sound, 
when configured, plays once or continuously.
An exception is that an alarm takes priority over any alert. If an alert occurs while an 
alarm is present, the alarm has priority. If an alert occurs followed by an alarm, the 
alarm overrides the alert.
When setting up conditions, the borders of the ranges can be configured to be either 
inclusive or exclusive. Ranges cannot overlap.
If the analog parameter selected is an enumeration, then configuring the alarm 
conditions is done in a different way. Instead of entering a numeric value, the operator 
selects an item from the list of available choices applicable to the parameter.

Sounds
Sounds serve to alert the attention of the user when an LED state changes in one of 
the opened schemas in the One-Line Viewer. Reset, alert, and alarm sounds are 
defined in the File > Preferences > Audible Alarms menu. You can set these sounds 
to any .wav files, and some are included with installation of Viewpoint Monitoring. The 
default folder is C:\ProgramData\EnerVista\Viewpoint Monitoring\My 
Documents\Sounds

Mute sound
The Mute Sound button at the top-right of the window mutes any configured audible 
alarm, alert, or status change.
The button toggles from sound on  to sound off .

Silence alarms and alerts
When an LED is active, it starts flashing the color associated with the LED type: red for 
alarm, yellow for alert. If an LED indicator is configured as type Status, it does not 
have to be acknowledged and does not flash while in an active condition.

Priority Level 4 - Highest

 Unknown Communication failure or configuration problem

 Normal LED is in normal condition

 Status Lowest priority

 Alert Medium priority

 Alarm Highest priority
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Once an LED indicator changes state and goes from a solid green color to a flashing 
red/yellow color, a sound file plays continuously (by default) until either the 
Acknowledge button is clicked or the Mute Sound button is enabled. The 
Acknowledge button is located at the top-right toolbar when a schema is opened in 
the One-Line Viewer.

Figure 51: Acknowledge button turns off alarms and alerts

The function of the Acknowledge button is to
• Silence the Alarm, Alert, Status, and Reset sounds
• Change a flashing red/yellow LED to either a solid red/yellow or to a flashing 

green
• Reset a flashing green LED back to its solid green default state
When the acknowledged LED indicator returns to a normal condition, the color of the 
LED changes from a solid red/yellow to a flashing green and the Reset sound file 
plays continuously (by default).
The flashing green indicates to the operator that there was an LED indicator with an 
acknowledged condition that changed back to a normal condition. The flashing green 
state now needs to be acknowledged again. Acknowledging the flashing green LED 
stops the sound. Click the Acknowledge button to reset the flashing green LEDs to a 
solid green state.
The function of the Reset button is to
• Reset all indicators whose alarms have been triggered and Acknowledged. The 

indicators go from a solid color back to a grey color.

Figure 52: Reset button resets alarm

Whether an alarm or alert plays once or continuously is set in the Annunciator panel in 
the Audible tab.

Add LED indicator
There are two ways to add an LED indicator to a schema, as follows:
• By selecting the LED icon, located on the Switch Gear and Control toolbar in the 

One-Line Editor
• By creating the LED indicator through the properties of an analog component/

parameter
The figure shows an example. When the motor starts, an alert generates. When the 
motor stops, an alarm generates.
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Figure 53: Configuring alert and alarm

As another example, an alarm generates when the Ethernet connection goes down.

Figure 54: Alarm for failed Ethernet connection

Analog and digital indicators are outlined here. The analog format enters normal 
equations, while the digital formula performs AND, OR, and NOT calculations.

Add analog LED indicator
An analog format enters normal equations. An LED indicator can be added.
There are two ways to add an LED indicator on an analog schema. The direct way is 
to select the LED icon and place the icon in the schema work area. The indirect way is 
by means of the analog component/parameter.

Method 1: Direct
To create an analog indicator:

1. In the main window of Viewpoint Monitoring, click the One-Line Editor option. 
The window opens.
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2. Click the LED  icon on the Switch Gear and Control toolbar. (If the toolbar is 
not present, enable it under the View > Toolbar menu.) The Create LED window 
opens.

Figure 55: Switch Gear and Control toolbar

3. Select the Analog option, then the size of the LED indicator. The size is either 
Small or Large.

Figure 56: Selecting the type of analog indicator

4. After selecting the size, press the left mouse button at the location on the schema 
to place the LED indicator.

Figure 57: Unconfigured indicator

5. Double-click the LED indicator and edit the properties to attach the LED indicator 
to a device and an analog parameter. For proper functioning, the LED needs to 
have at least one range defined. The multiplier can also be selected in order to 
adjust Viewpoint Monitoring’s displayed value to match the value displayed by a 
device.
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Figure 58: Configuring the analog indicator

For the LED indicator to work properly, there needs to be at least one alarm 
condition. The number of alarm conditions that can be created for each LED is 
unlimited.
Each range condition entered can be configured as one of two Types: Alarm or 
Alert.
Click the OK button to save and exit.

6. After specifying a device and an analog parameter, the LED changes to its 
normal-condition state (green). If not, click the One shot test button on the menu 
bar or press the F5 key.

Figure 59: Configured indicator

Method 2: Indirect
In the One-Line Editor, all of the analog components found in the Gauges toolbar can 
be configured to show an alarm/alert state, except for the multi-value circle, the multi-
value bar, and the phasor graph.
When an analog parameter has a condition configured, the parameter displays with a 
double border.

Figure 60: Double border indicates alert/alarm configuration

If an analog component has conditions defined, the Line, Fill, and Font settings for the 
parameter cannot be changed. This means that the parameter's color is predefined to 
be green (normal), red (alarm) or yellow (alert).
There is a Create LED check box located in the bottom left of the parameter 
properties window to create a small LED that has the same condition properties as the 
analog parameter being edited.
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To create an analog indicator:

1. In the One-Line Editor, access the Attach to tab of the parameter.
2. Enable the Create LED check box at the bottom-left of the window. This creates a 

small LED that has the same condition properties as the analog parameter being 
edited.

Figure 61: Adding an indicator for an analog component

3. Click the OK button to save and exit. The LED changes to its normal-condition 
state (green). If not, click the One shot test button on the menu bar or press the 
F5 key.

Add digital LED indicator
 A digital formula performs AND, OR, and NOT calculations. An LED indicator can be 
added.
To add a digital indicator:

1. In the main window of Viewpoint Monitoring, click the One-Line Editor option. 
The window opens.

2. Click the LED  icon on the Switch Gear and Control toolbar. (If the toolbar is 
not present, enable it under the View > Toolbar menu.) The Create LED window 
opens.

Figure 62: Switch Gear and Control toolbar

3. Select the Digital option, then the size of the LED indicator. The size is either 
Small or Large.
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Figure 63: Selecting the type of digital indicator

4. After selecting the size, press the left mouse button at the location on the schema 
to place the LED indicator.

Figure 64: Unconfigured indicator

5. Double-click the LED indicator and edit the properties. In the Attach to tab, edit 
the LED properties to attach the indicator to a device and a parameter. The 
indicator can also be configured to become active when the digital parameter has 
a value of 0 by enabling the Reverse Indication check box. The LED indicator 
shows the current state of device's digital parameter (0 or 1).

Figure 65: Configuring the digital indicator

6. In the General tab, select the LED Type. A digital LED indicator can be one of 
three LED types: Alarm, Alert, or Status.
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Figure 66: Selecting the type of digital indicator

7. Click the OK button to save and exit. The LED changes to its normal-condition 
state (green). If not, click the One shot test button on the menu bar or press the 
F5 key.
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Formula editor
The Formula Editor is a tool available within Viewpoint Monitoring to create Virtual 
Variables. These Virtual Variables are based on values from relays that can be 
modified with simple math operators and trigonometric functions. Up to 1,000 formulas 
can be added.
Formulas can be added, used, duplicated, imported, exported, updated, and deleted. 
The figure shows examples.

Figure 67: Formulas

Formulas are stored in the EVVPmonitoring.for file. This file is located in the 
installation folder where EVVPmonitoring.exe is located, for example 
C:\Program Files (x86)\Enervista\EnerVista Viewpoint Monitoring. The file contains a 
list of records. Each line in the file is a comma-delimited record, where each record 
defines the properties for a single formula.

Add formula
To add a formula:

1. In the main window of Viewpoint Monitoring, click Tools > Formula Editor. The 
window opens, with any existing formulas listed.

Figure 68: Accessing the Formula Editor

2. Click the Add Analog or Add Digital button. The analog format enters normal 
equations, while the digital formula performs AND, OR, and NOT calculations. 
The Edit Formula window opens.
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Figure 69: Formula Editor window

3. Use the graphical keypad and buttons displayed to enter the formula. Use the 
mouse to move the cursor position and to highlight blocks of the formula.

Figure 70: Analog formula window

Formula Name — Name of formula. Required field.
Units — The units of measure for the formula. Required field.
Device — Select a device from which the parameters are selected. The device is 
used only as a template. If you reference another, similar device, then the same 
formula is available to other devices.
Formula — Enter the formula. Click the Parameter button to insert a parameter 
variable in the formula. You then click it to select this parameter from the drop-
down box containing a list of all possible analog parameters for this particular 
device.
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+ — In the example shown in the previous figure, one parameter value is to be 
added to another. The plus sign appears after the first parameter.
Del — Click this button to delete any selected formula entry, for example when 
you have two parameter fields and only want one.
Max — Computes the maximum among operands in brackets. Available only for 
Analog formulas. The following figure shows how to use the Max feature.

Figure 71: Maximum of several operands

4. If applicable, add any other operator, for example by clicking the + button.
5. Click the Evaluate button to have the formula parameters resolved 

(communication requests retrieve data values). Instead of the formula, all of the 
individual parameter values and the formula results display.

6. Click the Ok button to save and exit.

Use formula
In the One-Line Editor window, for example, device formulas are accessible in any 
parameter list. The list of formulas created for a device is appended to the parameter 
list of a device. Analog formula names are prefixed with "*" to differentiate the formulas 
from the device's analog parameters. Digital formula names are prefixed with '#' to 
differentiate the formulas from the device's digital parameters.
The figure shows the component properties of a multi-value circle gauge. "Formula 1" 
was previously created for the device and is seen in the analog parameter list prefixed 
by "*".
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Figure 72: Using an analog formula prefixed with *

Duplicate formula
To copy a formula:

1. In the main window of Viewpoint Monitoring, click Tools > Formula Editor. The 
window opens.

2. Select a formula.
3. Click the Duplicate button.

Import formula
Files of the .for format can be imported.
To import a formula file:

1. In the main window of Viewpoint Monitoring, click Tools > Formula Editor. The 
window opens.

2. Click the Import button.
3. Select the file. Viewpoint Monitoring reads the records from the selected file and 

appends the formulas to the existing formula file.

Export formula
A formula can be exported in the .for format. This is simply a "Save As" feature. The 
data is not reformatted.
To export a formula:

1. In the main window of Viewpoint Monitoring, click Tools > Formula Editor. The 
window opens.

2. Click the Export button. The window opens.
3. Enter a file name and click the Save button.
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Update formula
To edit a formula:

1. In the main window of Viewpoint Monitoring, click Tools > Formula Editor. The 
window opens.

2. Select the formula and click the Edit button, or double-click it. The window opens.

Delete formula
To delete a formula:

1. In the main window of Viewpoint Monitoring, click Tools > Formula Editor. The 
window opens.

2. Select the formula.
3. Click the Delete button and confirm the deletion.
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Online help
To view this instruction manual, click Help > Contents.
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EnerVista Viewpoint Monitoring

Chapter 4: IED Dashboard

IED Dashboard

This chapter outlines how to use the dashboard.
• Access dashboard
• Access device front panel
• Import templates
• Toolbars and buttons
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Introduction
The Plug & Play IED (Intelligent Electronic Device) Dashboard allows you visualize the 
status various monitored devices. Devices can be added through the Device Setup to 
create representations devices being monitored.  
The views can be customized and updated to reflect newly setup devices

Figure 73: IED Dashboard

Each device within the dashboard has its own configured plug and play screens, as 
shown in the following figure. These screens have navigation buttons at the top that 
vary by product. The LED indicator at the top right of the screen shows the 
communication status of the device and is green when communicating successfully 
with the device. The Main Menu button returns the view to the IED Dashboard.

Figure 74: Dashboard for a product

The following figure shows an example for a PQMII Power Quality Meter device to 
instantly view the following critical information:
• Power quality and equipment status
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• Load unbalances using real time and maximum and minimum values
• Consumption and cost of energy using inputs from revenue meters
• Amount of total harmonic distortion on the power system
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Figure 75: Viewing critical information quicklyDashboard for a product
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The visualization of data in the device screens also highlights specific features of the 
device offering.  For example, in the 859, 869 the Electrical Signature Analysis (ESA) 
functionality is visualized in the device screen under the ESA tab: 

Figure 76: ESA Functionality
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New releases/updates of Enervista Viewpoint Monitoring provides support for new 
devices as well as updates to existing devices.  The updates are detailed in the 
release notes for each release.
As part of the Enervista Viewpoint Monitoring v8.15, support for the Multilin Agile and 
MM300 Enhanced were added providing data collection, monitoring and visualization.

Figure 77: Multilin Agile and MM300E supported in V8.15
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Access dashboard
Add devices using Device Setup before accessing the dashboard. See the Quickstart 
Guide to add devices.
To access the dashboard:

1. In the main Viewpoint Monitoring window, click the IED Dashboard option. The 
window opens.

Figure 78: Access the dashboard from the main window

2. When no devices have been set up within the software for use, the only available 
option is to Import Templates.

Figure 79: Dashboard when no devices set up

When devices have been set up within the software for use, they appear in boxes. 
The device needs to be configured in the Device Setup window with Plug and 
Play Enabled to allow display here.

Figure 80: Device configured to allow display (Plug and Play Enabled)
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When a device changes state between online and offline, it can take 30 seconds 
to a minute for the status to be updated in the window. The following figure shows 
one device that is online and one that is offline, as indicated by the green and gray 
LED indicators.

Figure 81: Dashboard when devices set up

3. To access the dashboard for a product, click its Dashboard button. The window 
opens.

The interface is explained at the end of this chapter.
Note: If configured and used, the User Definable P&P screens are only available on 
the Viewpoint Monitoring instance. Remote access through Viewpoint Monitoring 
ViewNode does not support User Definable P&P (Plug & Play) screens as the plug 
and play files for different devices type are not copied or dynamically(published) from 
Viewpoint Monitoring instance to the remote workstation with ViewNode installed.  



CHAPTER 4: IED DASHBOARD ACCESS DEVICE FRONT PANEL

ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL 69

Access device front panel
The front panel of a device can be accessed in Viewpoint Monitoring, which creates a 
virtual view. For a device that supports remote capability, the device can be controlled 
remotely through this interface. It does not matter if the device is online or offline, but 
control can only be done when the device is online. The ability to make changes 
depends on user account permissions and whether login is required in Viewpoint 
Monitoring. For example, buttons are inactive for a Guest user account.
To access the front panel of a device:

1. Access the dashboard window.
2. Click the Front Panel button for the device. The window opens, which varies by 

device.

Figure 82: Click Front Panel button to view device

3. Click a button, for example the arrow keys to scroll through the menu for setup or 
actual values. When the device is offline and a key is clicked, a "failed" message 
displays. Or click a panel to open a larger view, then click a button to control the 
device.
To send a command to the device, by default the CTRL key needs to pressed 
while the command button is clicked. This does not apply to navigation with arrow 
keys, only to command entry. This setting is configured under File > Preferences 
> Control.

4. Exit by clicking the X at the top-right of the window.
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Figure 83: Controlling a device in Viewpoint Monitoring
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Import templates for customization
The virtual views of devices in the dashboard are templates. These templates are 
included with installation of Viewpoint Monitoring. These are the demonstration files 
referred to earlier in this document. They can be imported into Viewpoint Monitoring, 
opened, and customized for use.
With hidden files and folders showing (as set in the Control Panel in Windows), files 
can be imported from the following folders:
C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents\Plug and 
Play\Templates\
C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents\Examples\
To import templates:

1. In the main Viewpoint Monitoring window, click Plug & Play > Import Templates. 
The option can be inactive when using a trial version of the software. A window 
opens.

2. In the Templates or other folder, select one of the .sf files. At the prompt, verify the 
import of all information associated with that file.

Figure 84: Importing a template

3. Open the file in the One-Line Editor function, for example.
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Figure 85: EPM9900 template open in the One-Line Editor
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Toolbar and buttons
The dashboard window contains the following information.

Figure 86: Product box

--- Select Device List with the name and communication status of 
each configured device belonging to the product 
group. The status indicator is green when 
communications is established between Viewpoint 
Monitoring and a device.

Dashboard Opens the virtual-view template associated with the 
highlighted device in the Select Device window

Waveforms Opens the COMTRADE viewer so that 
oscillography/waveforms downloaded from the 
device can be viewed

Front Panel Opens the virtual front panel associated with the 
highlighted device. The virtual front panel allows 
direct access to the device.
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EnerVista Viewpoint Monitoring

Chapter 5: Device Setup

Device Setup

This chapter outlines device configuration within Viewpoint Monitoring.
• Add device
• Add and manage devices with custom file editor
• Import device
• Update device
• Delete device
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Introduction
This chapter describes the various elements of adding, editing and deleting devices.
A device needs to be added to Viewpoint Monitoring before it can monitored.  This 
requires the device information which can be added automatically, manually, or by 
import as detailed in this section.
Devices in Viewpoint Monitoring are defined by the following files: 
- .cdd definition file 
- .bmp image file
These files are located in the installation folder for Viewpoiint Monitoring 
(C:\ProgramData\EnerVista\Viewpoint Monitoring\Devices).
The Custom File Editor provides the capability to add new GE Vernova and non-GE 
Vernova (third-party) devices. 
Finally, this chapter also details how to update and delete devices in Viewpoint 
Monitoring.
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Add device
Refer to Chapter 1 Introduction > Quickstart > Add a Device for instructions on adding 
or importing GE Vernova devices and adding non-GE Vernova devices for which you 
have a .cdd file. 
To add other devices, use the next section Add and manage devices with custom file 
editor to manually define and add a device.
The current list of devices supported is shown in the Enervista Viewpoint Monitoring 
release notes which can be found on the website or also under Start > All Programs 
> EnerVista > Monitoring Release Notes after upgrading.
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Add and manage devices with custom file editor
The Custom File Editor allows you to define a new device to be used within Viewpoint 
Monitoring as well as edit and delete devices already defined. This allows Viewpoint 
Monitoring to communicate with any device that uses the Modbus protocol for 
accessing data. You normally use the Custom File Editor when automatic import or 
automatic discovery of devices does not work.
To add a new device type, you need a product image in the .bmp format. This figure is 
for use in the IED Dashboard and is typically a front view of the device. The size is 
about 34 by 50 pixels. Place the file in the C:\ProgramData\EnerVista\Viewpoint 
Monitoring\Devices folder, which can require that you show hidden files and folders in 
the Control Panel of Windows. Or instead of creating a new image, an option is to use 
an existing image in that folder, for example for a similar device.
To define a device:

1. In the main window of Viewpoint Monitoring, click File > Custom File Editor. The 
window opens.

2. Scroll through the Device and Versions lists to view if the device is listed.
Device — Displays a list of devices already defined that can be used in Viewpoint 
Monitoring. UR Series devices are not listed because UR products are supported 
differently; the memory maps are included in the code of Viewpoint Monitoring for 
all supported UR products and versions. The B95Plus of the URPlus series is not 
listed because it is not supported.
Version — Displays a list of all versions available for a product.

Figure 87: Adding a device

3. If the device is listed, skip this step.
If the device is not listed, there are two ways to add it.
3.1. The first way to add a device is to select a similar device and version, click 

the Edit button, rename it in the Device Identification field, and exit. This 
creates another entry in the Device and Version lists.

3.2. The second way to add a device is to add a completely new device, as 
follows.
Click the Add button. A window opens.
Complete the fields.
Product — The model or brand of the product. All text is converted later to 
uppercase.
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Version — The version number of the device firmware without punctuation, 
for example 100 instead of 1.00.

Figure 88: Defining a device

Click the OK button to save and exit. Select the Device and Version. Click 
the Load Image button.
In the window that opens, upload a figure to display in the IED Dashboard 
in Viewpoint Monitoring. The default folder for the other images is the 
C:\ProgramData\EnerVista\Viewpoint Monitoring\Devices folder. Only the 
.bmp format is supported. Any other uploaded file type does not display.

4. In the Custom Device Definition Maintenance window, click the Edit button. The 
Custom Device Definition window opens.

5. Add the Modbus entries or edit any existing .cdd file that displays. The window is 
explained in the next section.

6. To add the new custom device type to the communication server, with the Device 
and Version selected, click the Apply to Server button.

7. Click the Close button to exit.

Custom Device Definition window
This section is for advanced users.
The Custom Device Definition window is used to configure existing and new devices 
using Modbus addresses. Changes made here affect the .cdd file for the device. The 
window varies with device, for example the check boxes displayed. By completing this 
window, you manually create a representation of the memory map of the device in the 
form of a .cdd file. It is for use within Viewpoint Monitoring only.
There is no option to import a .cdd file.
When entering in a new Modbus entry in the spreadsheet part of the window, the 
Label and Modbus Address are required. All other fields load automatically with 
default values.
You add only the registry entries that you want to read/monitor, not the entire memory 
map of a device. The entries added are usually actual values, such as power, energy, 
and currents. You look them up in the communications guide / memory map supplied 
with the device.
All entries in the custom table need to be in the communications guide / memory map 
supplied with the product.
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Figure 89: Editing device information

Device Identification — Displays a text description for the device. For an existing 
device, if you change the entry here and exit from the window, a new device type is 
added to the Device and Version lists.
Check for unique Modbus Address (check box)— Enable to have the software 
prompt when you enter a Modbus address that is not unique. You must then change 
the value in order to continue. The only exception to this rule is when you want to 
manipulate bit values for a specific Modbus entry. Thus, if the data type is set to a bit 
for a particular Modbus Address mapping, you can use that Modbus Address in a 
different entry.
Hex/Dec (radio buttons) — Changes the way that the Modbus Address is entered or 
viewed in the spreadsheet. 
Received data is LSB-MSB order (check box; not always displayed) — Enable to 
have the register stores values with the byte order from least-significant bit (LSB) 
being in the first byte position to most-significant bit (MSB) being in the last byte 
position. By disabling the check box, it is assumed that the register stores values in 
the reverse byte order.
Byte Swap (check box; not always displayed) — Modbus is a protocol where data is 
read as 16 bits (named words) from the devices. A word is composed of two bytes 
(each byte is 8 bits). For some devices, the bytes need to be swapped in order to 
display the information correctly in Viewpoint Monitoring.
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Polling Optimization (check box; not always displayed) — When enabled, if 
Viewpoint Monitoring is asking for information from adjacent addresses, the 
information is requested from the device as a block (for example read address 1000, 
one word, and read address 1050, one word, the first representing the Ia RMS and the 
second representing some voltage Va). If all addresses between 1000 and 1050 are 
valid, the request from the device is read from block 1000 to 1050 in one transaction. 
After that, Viewpoint Monitoring picks up the required information from that block. 
Some devices do not allow this kind of block reading. If you turn the Polling 
Optimization off, a request is made to read one word from address 1000 in our 
example, and a separate request is made to read one word from address 1050. This is 
slower in general.
Edit Force Coil (button) — To enter preset operation codes that the device has been 
programmed with, that the user can perform. For third-party devices, the Force Coil is 
the only method of sending control commands to the device. See the device's 
communication guide, specifically for a description of the device's Modbus Command 
05 implementation.
Edit Enumerations (button) — Enumeration refers to a list where we read a numeric 
value but want to display it as more user-friendly text. An example is that F100 can be 
entered as F100 or something more convenient, such as FormatYesNo.
Use this button to create number to text string mappings. These mappings can then be 
used to format the display of individual registers. A Modbus entry can use these 
mappings by entering a list name (first column in the window that opens) in the List 
Reference column.
To create the list mapping:

1. Click the Edit Enumerations button. The window opens.
2. Click the New icon near the top left. It is the square icon. A blank entry is added.
3. Enter a unique string name for the mapping in the Enumerations section.
4. Enter the list of numeric values and their corresponding string values.

Figure 90: Defining enumeration codes

For the following fields, when entering a new Modbus entry in the spreadsheet part of 
the window, the Label and Modbus Address are required. All other fields load 
automatically with default values.
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Label — Unique name to identify the Modbus entry. Displayed when showing the 
value for this Modbus entry.
Modbus Address — The numeric address location for the Modbus entry. Enter the 
address in hexadecimal format, such as 000c or dc4e.
After entering the Label and Modbus Address, the rest of the row populates. Some 
of the other fields have drop-down lists for additional configuration or check boxes to 
enable or disable functions.
Data Type — A drop-down list that allows selection of the data type that the number 
represents. The table shows the options. 
CFT refers to format type. 
SINT refers to a signed integer, which can be a positive or negative number. 
UINT refers to an unsigned integer, which is a positive number. 
Integers are used in the software to define analog inputs/outputs. 
Boolean values are used in the software to define digital inputs/outputs, where a 
Boolean value can have two possible values, such as true or false, or 0 or 1.

Table 5: Data type options

Data type Description

CFT_BCD_TIMESTAMP Modbus data item has an eight-bite long value. The value is encoded 
as first byte = hour, second byte = minute, third byte = second, fourth 
byte = millisecond, fifth byte = month, sixth byte = day, and the 
seventh and eighth byte = year. It is four Modbus registers long. 
Viewpoint Monitoring displays the data value in the format, such as 
'Jan 27 15 10:20:30am'.

CFT_BIT 16-bit bitmask value that is converted using mask and shift 
operations.

Modbus data item has the single bit value 0 or 1. However, when this 
data item is read from the Modbus device, a single Modbus register, 
16 bits, is always being read. You must enter the bit mask in the Max 
column to specify which bit is to be used. The bit mask value is 
always 2s power based, and counted from right to left. If your 
CFT_BIT is the first bit from the right in the 16 bits Modbus register, 
you need to specify the max value as 1 (2^0. 0x0001). If your 
CFT_BIT is the second bit in the 16 bits Modbus register, you need 
to specify the max value as 
2 (2^1. 0x0002). If your CFT_BIT is the ninth bit from the right in the 
16 bits Modbus register, you need to specify the max value as 
256 (2^8. 0x0100). If your CFT_BIT is the sixteenth bit from the right, 
you need to specify the max value as 32768 (2^15. 0x8000). Hence, 
you enter the max value as 2^(bit count - 1), where the bit count is 
from the right to the left. CFT_BIT value also needs an enumeration 
to specify the text descriptions for the value 0 and 1.

CFT_BYTE A single byte value. However, Viewpoint Monitoring has to read at 
least a single Modbus register that is two bytes long. In this case, in 
the Max column, you need to enter a value to specify how many 
counts the bits have to be shifted to the right for the 16-bit Modbus 
register value. Viewpoint Monitoring uses that value to shift the 
Modbus register value from the device, and it uses the lower byte of 
the 16-bit value. For example, if the 16-bit Modbus register value is 
0x02C7, the max value specified in the Max column is 8, Viewpoint 
Monitoring shift the bits of 0x02C7 eight times to the right, and after 
the shift, the value is 0x0002, and the lower byte 0x02 is used.

CFT_COIL_BIT The same as CFT_BIT data type, except that the Modbus function 1 
is used for reading the data item

CFT_DATE A four-byte long value. The first two bytes represent the year, the 
third byte represents the day, and the fourth byte represents the 
month. Viewpoint Monitoring presents the value in the format of 'MM/
DD/YYYY'. 



CHAPTER 5: DEVICE SETUP ADD AND MANAGE DEVICES WITH CUSTOM FILE EDITOR

ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL 83

List Reference — Configured with the Edit Enumerations button, which creates a 
drop-down list here for selection. It maps the output values for this specific register to a 
text string. The text string displays instead of the numeric value on the device. Click 
the cell to select the enumeration mapping from the drop-down list. You can define the 
number-to-string mapping by clicking the Edit Numerations button.

CFT_ENUMERATION Enumeration stored in an unsigned 16-bit integer. Modbus data item 
has a fixed set of values, and each value in the set has a 
corresponding text description. A named enumeration has to be 
created in Enumeration Editor for the values and their corresponding 
text descriptions. Select the enumeration name for this data type in 
the List Reference column. This data type is two bytes long (one 
Modbus register).

CFT_FLOAT2 IEEE floating-point value with upper and lower 16-bit words 
reversed.
Modbus data item has the value of floating point. However, the word 
order has to be swapped by the Viewpoint Monitoring system to 
correctly present the value. It is four bytes long (two Modbus 
registers).

CFT_FLOATING_POINT Modbus data item has the value of floating point. Decimal points can 
be specified in the Decimals column. If the value is range-bounded, 
the minimum and maximum values can be entered in the columns of 
Min and Max. Floating point value is four bytes long (two Modbus 
registers).

CFT_HEX2 Modbus data item is a Modbus register, 16 bits long. Viewpoint 
Monitoring presents the value in the format of '0x?? 0x??', such as 
'0x1A 0x20'.

CFT_INPUT_BIT The same as CFT_BIT data type, except that the Modbus function 2 
is used for reading the data item

CFT_MILLI_SEC_COU
NTS

A six-byte long Modbus data item. It represents the milliseconds 
since Jan. 1, 2000, 00:00:00. Viewpoint Monitoring system presents 
it in the format of 'MM/DD/YYYY HH:MM:SS.ssss'. It is three Modbus 
registers long.

CFT_SINT16 Signed 16-bit integer.
If the value is range-bounded, the minimum and maximum values 
can be entered in the columns of Min and Max. It is two bytes long 
(one Modbus register).

CFT_SINT32 Signed 32-bit integer.
If the value is range bounded, the minimum and maximum values 
can be entered in the columns of Min and Max. It is four bytes long 
(two Modbus registers).

CFT_SINT64 Signed 64-bit integer (four Modbus registers long)
CFT_TEXT Modbus data item has the value of text string. You must enter how 

many characters in this text string in the Max column. 
CFT_TIME A four-byte long value. The first byte represents the hundredth of a 

second. The second byte represents the second. The third byte 
represents the minutes, and the fourth byte represents the hours. 
Viewpoint Monitoring presents the value in the format of 
'HH:MM:SS:hh'. 

CFT_UINT16 Unsigned 16-bit integer.
If the value is range-bounded, the minimum and maximum values 
can be entered in the columns of Min and Max. It is two bytes long 
(one Modbus register).

CFT_UINT32 Unsigned 32-bit integer.
If the value is range-bounded, the minimum and maximum values 
can be entered in the columns of Min and Max. It is four bytes long 
(two Modbus registers).

CFT_UINT64 Unsigned 64-bit integer (four Modbus registers long)

Data type Description
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Actual Values (check box) — Identifies if this register stores an actual value. When 
enabled, an Actual Value register is read from the device using the Modbus function 4. 
When disabled, the read uses Modbus function 3. This does not apply for the 
CFT_COIL_BIT and CFT_INPUT_BIT data types.
Max \ Length \ Bit — Largest stored value. When the Data Type is a String, the 
maximum value represents the maximum string size.
Decimals — Enter the number of decimals to display for the Modbus value.
Units — Enter the unit of measure that the register value is in, for example Hz, Hz/s, 
or kV. The unit string is appended to the data value prior to displaying the data.
One-Line Editor (check box) — Enable to allow the One-Line Editor to see this 
register mapping.
Annunciator Panel (check box) — Enable to allow the Annunciator function to see 
this register mapping.
ID — Unique identification. Examples are PRODUCT_ID and 
UR_DATA_AUTOMATION_VIRTUAL_INPUT_STATES107. These values are 
generated automatically by the editor, for example if the label entered in the first 
column is "Ia RMS," then the ID generated is IA_RMS.
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Apply to server
Clicking the Apply to Server button allows the user to add new custom device type to 
the communication server. The button is active only for new device types. Select the 
Device and Version before clicking the button.

Delete device with custom file editor
To delete a device:

1. In the main window of Viewpoint Monitoring, click File > Custom File Editor. The 
window opens.

2. Select the Device and Version.
3. Click the Delete button and confirm the deletion. This deletes the .cdd file from 

Viewpoint Monitoring. The default folder with the files is 
C:\ProgramData\EnerVista\Viewpoint Monitoring\Devices

4. Manually delete the .bmp image file if you know its name and folder location. The 
default folder is C:\ProgramData\EnerVista\Viewpoint Monitoring\Devices 
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Import device
During installation of the Viewpoint Monitoring software, the system checked 
automatically for devices and provided the opportunity to import configurations. The 
function also can be invoked manually.
Each time that the software launches, it checks for existing 32-bit xxxPC programs (for 
example, 469PC and PQMPC). The xxxPC environment files are searched and any 
new devices are added to a list from which you can select the devices to import into 
Viewpoint Monitoring.
In addition to checking for xxxPC programs, a system scan is done for the EnerVista 
UR Setup environment file and EnerVista URPlus Setup environment files.
There are two options for importing devices. One is to search. The second is to specify 
the file location. First try the search, then use the second option to browse for the 
device.

Figure 91: Importing devices

To import devices:

1. Click File > Import Devices > Perform Search.
If you import any devices, verify in Device Setup that the devices were imported; 
sometimes it appears that a device is to be imported but then it is not.

2. If Viewpoint Monitoring cannot locate automatically the environment file, select 
Specify Location instead. This allows you to browse and select a specific 
environment file (.ENV or .DS file).
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Update device
Device information can be updated, for example when the device is upgraded or 
moved.
To update device information:

1. In the main window of EnerVista Viewpoint Monitoring, click the Device Setup 
option. The window opens.

2. Expand the Ethernet or Serial category as required, and click the device. 
Information for the device displays on the right side.

3. Edit the fields. See the Quickstart Guide for an explanation of the fields.
4. Click the Ok button to save and exit.
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Delete device
Device configuration can be deleted to remove the device from the software. Deleting 
a device does not delete any files manually saved for it, such as a .ap alarm file.
To delete a device:

1. In the main window of EnerVista Viewpoint Monitoring, click the Device Setup 
option. The window opens.

2. Expand the Ethernet or Serial category if required, and click the device. 
Information for the device displays on the right side.

3. Click the Delete button, and confirm the deletion.

Figure 92: Deleting a device
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Offline Mode

In some cases, users may want to place devices temporarily offline (e.g. the device is 
off for maintenance, servicing, checking)
The device can be set to offline, and will remain visible.  When the device is set offline,  
events, waveforms, timedownload will not be performed for that device. 
For the devices that are set offline, the communication server will only try to connect 
again after 24 hours versus more frequency (within one minute) if a device is not 
responding.
When a device is set to offline there can be a significant improvement to the data 
refresh performance as there is a reduction to the communications connection retries 
for the offiline device.  This improvement to the data refresh performance for is 
especially applicable when there are devices connected through a communications 
gateway via a daisy chain connection (e.g. legacy devices ( e.g. PQMII, 469, SR, etc). 
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EnerVista Viewpoint Monitoring

Chapter 6: One-Line Editor

One-Line Editor

This chapter outlines use of the One-Line Editor.
• View demonstration files
• Draw schema diagram
• Save file
• Connect/test with One Shot
• Update schema diagram
• Delete schema diagram
• Edit and view simultaneously
• Change page size and units
• Create custom symbols
• Toolbars and buttons
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Introduction
The One-Line Editor is used to draw diagrams, called schemas, for equipment 
monitoring and control. It is used to create interactive one-line, or single-line, diagrams 
that are connected to devices to monitor and understand remote site configuration as 
well as to view readings and status updates. An example is to create an alarm so that 
you see when a motor is shut off.
You create a schema in the One-Line Editor, then view the data from the device in the 
One-Line Viewer (next chapter).
The toolbars and buttons are explained at the end of the chapter, as well as how to 
change page size, units of measure, and create custom symbols.
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View demonstration files
Examples of one-line diagrams can be viewed.
These and other files can be imported into the software and customized for use.
To view demonstration files:

1. In the Control Panel for Windows, change the Folder Options so that hidden files 
and folders show.

2. In the main Viewpoint Monitoring window or the One-Line Editor, click File > Open 
and open any .sf file in the following folders:
C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents\Examples\
or for UR series devices
C:\Program Files (x86)\GE Power Management\URPC\Data\Demo\ 
The diagram opens in the One-Line Editor window.

3. When done, turn off hidden files and folders.

Figure 93: Example of one-line diagram



94 ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL

DRAW SCHEMA DIAGRAM CHAPTER 6: ONE-LINE EDITOR

Draw schema diagram
The One-Line Editor allows you to create one-line diagrams, with standardized 
symbols representing power system assets, such as transformers, breakers, current 
transformers (CTs), and potential transformers (PTs). Support is also provided to add 
JPG and PNG images.

Figure 94: Example of diagram for monitoring motor status

Before starting, read the Toolbars and Buttons section at the end of this chapter to 
understand options and functions.

Figure 95: One-Line Editor Toolbars

It’s recommended to draw the entire diagram first, then configuring each symbol. 
The flow is as follows: 
• Add a title in the diagram
• Add symbols, such as breakers
• Add lines
• Add arrows
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• Add text
• Configure each symbol

Examples
Two examples follow.
• Display phase meter value
• Add breaker with on/off indicator

Display phase meter value
The following figure shows how to add a phase voltage meter value to display in real 
time.

Figure 96: Adding a metered value

Figure 97: Metered value in real time in One-Line Viewer
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Add breaker with on/off indicator
This example shows how to add a breaker, configure it, and show its status.

Figure 98: Breakers showing green "on" status

To add a breaker:

1. Add the breaker by clicking the Drawout Breaker icon  on the Switch Gear 
and Control toolbar, then clicking in the drawing.

Figure 99: Add breaker

2. Configure the symbol by double-clicking it. The properties window opens.
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Figure 100: Configuring the breaker

In the Attach to tab, enable the Automatic indication from check box, select the 
device from the Device drop-down list, select Virtual Outputs from the Category 
drop-down list, and select a virtual output from the Virtual Outputs drop-down 
list. The last item, the virtual output, is the one to be monitored.
Note that in this example, the breaker is being monitored and is not a control 
breaker. The Controls tab is used instead to configure a control breaker.

3. In the same window, add the status indicator. Enable the Manually operated 
symbol radio button, enable the Status check box, and select the On and Off 
colors, for example green for On and red for Off.

Figure 101: Setting colors to indicate when on and off

4. Click the OK button to save and exit from the window, then save the file. Clicking 
the breaker enables the on/off indicator to be toggled. Because it is not a control 
breaker, the breaker itself is not being turned on and off.



98 ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL

DRAW SCHEMA DIAGRAM CHAPTER 6: ONE-LINE EDITOR

Figure 102: Configured breaker, off

Draw diagram
To draw a schema diagram:

1. In the main window of Viewpoint Monitoring, click the One-Line Editor option. 
The window opens.

Figure 103: Access the editor from main window

2. To add a figure of a device, click the Device button  on the System Editor 
toolbar, then select the device by double-clicking the entry and selecting the 
device from the drop-down list. The device needs to already have been added in 
the Device Setup function.
In the example shown, the grey box above the device indicates that there is no 
communication with the device. To update the status of the device, click the One 
Shot

 Test button  on the System Editor toolbar. The LED indicator changes to 
green with communication.



CHAPTER 6: ONE-LINE EDITOR DRAW SCHEMA DIAGRAM

ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL 99

Figure 104: One-Line Editor window with a device added

3. Click one of the symbols from the toolbars and edit the properties of the symbol. 
Specifically, select from the Gauges, Switch Gear and Control, Symbols, or 
Transformers and Symbols toolbar. Only components in the Switch Gear and 
Control toolbar can be used for manual indication. Only components in the Switch 
Gear and Control toolbar can be used for control. To display any of the toolbars, 
click View > Toolbar.

4. Drop the parameter on the canvas by clicking a spot in the window.
5. Double-click the symbol to open the configuration window. Continue with the 

applicable procedure that follows:
– Add gauge parameter
– Add component for manual indication
– Add alarm or alert
– Add component for control
– Add a figure to a schema
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Add gauge parameter

To configure the component:

1. In the Attach to tab, select the device and parameter.

Figure 105: Setting device and parameter

2. Complete the General tab by either keeping the default Name or entering another 
one. The Type field reflects what is being added and cannot be changed.

3. The Line, Fill, and Font tabs provide options to set object borders, fill, and font.
4. Optionally set the Hyperlink tab to complete an action, such as open a file.
5. Click the OK button to save and exit the configuration window and return to the 

One-Line Editor window. Then save the One-Line Editor file.
6. In the main window of Viewpoint Monitoring, click the One-Line Viewer option to 

open the viewer. Open the file in One-line Viewer. Viewpoint Monitoring then 
reads the value from the device and shows it inside the Parameter symbol.
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Figure 106: Parameter display

Add component for manual indication
An example is the Send command to Virtual Input option, on the Switch Gear and 
Control toolbar.
To configure the component:

1. In the Attach to tab, select the Manually operated symbol radio button to 
specify that the component is a manual indicator. Select the Status to be either in 
the ON or OFF state. Optionally select the color to fill the component in each state 
(ON and OFF) if the selected component supports this function. The Show Text 
option displays On or Off in the One-Line Editor window.

Figure 107: Setting manual indicator

2. Complete the General tab by either keeping the default Name or entering another 
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one. The Type field reflects what is being added and cannot be changed.
3. The Line tab provides the option to set object borders.
4. Click the OK button to save and exit the configuration window and return to the 

One-Line Editor window. Then save the One-Line Editor file.

Figure 108: Parameter with text in One-Line Editor window

5. In the main window of Viewpoint Monitoring, click the One-Line Viewer option to 
open the viewer. Open the file in One-line Viewer. Viewpoint Monitoring then 
reads the value from the device and shows it inside the Parameter symbol.

Add alarm or alert
See the Add LED indicator section on page 48.

Add component for control
To configure the component:

1. In the Attach to tab, select the Automatic indication from radio button. Select 
the Device to which the component is connected. Select the indication Category. 
Select the specific item that you want the component to control.

Figure 109: Setting automatic indicator

2. Complete the General tab by either keeping the default Name or entering another 
one. The Type field reflects what is being added and cannot be changed.

3. In the Controls tab, enable the check box for control 1 or 2. Select the Device. 
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Select the control-type Category. Select the corresponding Category Force Coil 
or Virtual Input command below the Category. Change the text of the Command 
Name to what you want. Select a Value to send when control is initiated.
If you want another control function added to this component, enable the other 
check box for control 1 or 2 and complete the fields.

Figure 110: Controls tab

4. Optionally set the Hyperlink tab to complete an action, such as open a file.
5. The Line tab provides the option to set object borders.
6. Click the OK button to save and exit the configuration window and return to the 

One-Line Editor window. Then save the One-Line Editor file.
7. In the main window of Viewpoint Monitoring, click the One-Line Viewer option to 

open the viewer. Open the file in One-line Viewer. Viewpoint Monitoring then 
reads the value from the device and shows it inside the Parameter symbol.

Add figure to a schema
Follow the steps to add an image file to your schema work area. Viewpoint Monitoring 
allows bitmap files to be imported (.bmp, .dib, .jpg, .png).
To add an image of a device, see the Draw schema diagram section on page 94.
To add an image to the drawing:

1. Click the Image  button on the Drawing toolbar. A window opens.
2. Select the image.
3. Click the canvas to add the image.
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Save file
A one-line schema can be saved in the .sf format two ways.
• Absolute, such as C:\MyFiles\MyG60File.sf
• Relative, such as MyG60File.sf — Use this for remote ViewNode access
When the path is relative, it is relative to the My Documents folder of Viewpoint 
Monitoring. For example, if the path of the Viewpoint Monitoring documents folder is: 
C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents, the software 
searches for MyG60File.sf in that directory.
If the relative path is ...\TestDir\MyG60File.sf, the link opens the file from the 
C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents\TestDir folder.
All .sf files published from the Viewpoint Monitoring server are downloaded to a 
remote ViewNode computer in the C:\ProgramData\EnerVista\Viewnode\My 
Documents folder. If the path of the hyperlink is absolute, for example 
C:\MyFiles\MyG60File.sf, the link does not work on the Viewnode. When saving One-
Line diagrams, use relative paths if you plan to use the links on the ViewNode.
To save the file:

1. Click the Save icon on the toolbar.
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Connect / test with One Shot
You use the One Shot Test command in the One-Line Editor to see a one-time, actual 
value update for all digitals and analog components that are connected and configured 
in your current schema. For example, it shows that a device is connected.
To use the One Shot Test function:

1. In the One-Line Editor, click the One Shot Test button  on the System Editor 
toolbar. If the toolbar is not displayed, enable it under View > Toolbar.

Figure 111: System Editor toolbar

Any readings or values for any of your measurable components are cleared and 
within a five to 15 second period, new values display, showing the current 
readings for those connected and configured devices.

Figure 112: Device connected
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Update schema diagram
There are two ways to update the properties of a selected component: double-click the 
component, or right-click it and select Properties. This displays the Component 
Properties window used when adding the diagram, as outlined earlier.
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Delete schema diagram
To delete a diagram:

1. Locate the .sf file on the computer and delete it.
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Edit and view simultaneously
When editing a schema, you can view it in the One-Line Viewer at the same time. This 
allows you to view changes in real-time.
To edit and view a scheme simultaneously:

1. While in the One-Line Editor, click the Tools > One-Line Viewer menu. The One-
Line Viewer opens.

2. In the One-Line Viewer, open the same schema file that you are currently editing.
3. Switch between the Editor and Viewer using the tabs at the bottom of the screen. 

The tab with the letter "E" enclosed in a box is the Editor, and the tab with a blank 
or blinking indicator is the Viewer.

The figures show an example of a schema first in the Editor, then in the Viewer.

Figure 113: Example of schema in One-Line Editor
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Figure 114: Example of same schema in One-Line Viewer
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Change page size and units
The size of the work area in the One-Line Editor can be changed. Units of measure 
can be specified, for example inches or centimeters.
To change page size or units:

1. In One-Line Editor, click Edit > Measurements and Size. The window opens.
2. In the Size and Units tab, select the Unit of Measure, then change the Canvas 

Width and Canvas Height. For example, set the page size to 4 x 4 inches.

Figure 115: Page setup

3. In the Drawing Scale tab, set how much a unit represents. For example 1 inch on 
the drawing can represent 1 inch. If you set the ratio higher, for example 1 inch on 
the canvas represents 1 foot, the drawing area becomes much smaller.

4. Click the OK button to save and exit.
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Create custom symbols
The One-Line Editor is highly customizable and allows creation of symbols. If you 
want to use measurable digital components (not analog) that are not part of the default 
symbols, use the Custom Labels button to do so. These custom symbols are 
generalized digital components where the visual look of the OFF/ON states can be 
customized to whatever bitmap image files that you create or apply. The software also 
supports JPG and PNG formats.
To create a custom symbol:

1. Create or obtain bitmap images to use for the ON and OFF states.

2. In the One-Line Editor, click the Custom Symbol button  located on the 
Switch Gear and Control toolbar.

Figure 116: Switch Gear and Control toolbar

3. Click anywhere on your schema work area to place the custom symbol.
4. Either double-click the custom symbol area or right-click it and select Properties 

to open the window.

Figure 117: Properties of a custom symbol

5. Complete the fields as explained in previous sections for the General, Attach to, 
and other tabs. Specify the bitmap images to use in the Attach to tab.

6. Click the OK button to save and exit.
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Toolbars and buttons
The figure shows the toolbars available in the View > Toolbar menu. When you 
mouse-over an icon/button, its name displays.

Figure 118: One-Line Editor Toolbars

Links — To create link buttons or hot-spots on the schema that when viewed in the 
One-Line Viewer can navigate the user to another connected schema.
Drawing — To create basic lines, curves, text, and shapes for use in your schema.
System Editor — Basic functionality of creating/opening and saving schema files as 
well as providing access to certain One-Line Editor tools, such as "Insert Device" and 
the "One Shot Test."

Figure 119: UR device added with Insert Device tool

Zoom — To resize, zoom, and pan around the schema.
Align — To align two components in an variety of ways.
Nudge — To move components of your schema by minute lengths.
Structure — To group/ungroup components of your schema and also to move 
components in between the viewable layers of your schema.
Rotate — To rotate or flip the components created on your schema.
Layout — To adjust and size the components created on your schema.
Gauges — An assortment of interactive analog gauge symbols to represent their 
respective real-life components on a schema.
Symbols — Electrical diagram symbols to represent their respective components on a 
schema.
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Switch Gear and Control — Interactive digital symbols to represent their respective 
real-life components on a schema.
Transformers and Symbols — Transformer symbols to represent their respective 
components on a schema.

Links

Drawing

Hot Spot Creates a button that allows users to navigate to other 
schemas, functions, devices, or applications when clicked. 
Once the button is created, specify the schema to link to by 
double-clicking the Hot Spot button and editing the 
properties in the tab.

Link Draws connecting lines between two selected components. 
Once this tool is selected, select the first component to begin 
drawing connecting lines. Select the second component to 
stop drawing connecting lines.

 Select Used to select components. Click one component and then 
hold down the CTRL key to select others, or just drag an 
area that contains the components that you want to select.

Edit Vertices Shows vertices points for the current component that you 
have selected (if the component support vertices 
manipulation)

 Properties Shows the properties of the selected component

 Line Used to draw one line

 Polyline Used to draw connecting lines. Double-click to end drawing 
a component.

 Polygon Used to draw an enclosed variable-sided polygon. Double-
click to end drawing a component.

 Rectangle Used to draw a right-angle rectangle

 Polycurve Used to draw connecting curved lines. Double-click to end 
drawing a component.

 Close Curve Used to draw an enclosed connecting curved lined object. 
Double-click to end drawing a component.

 Ellipse Used to draw a elliptical component

 Text Used to add text to your schema
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System Editor

Zoom

 Image Used to insert a figure into your schema

New Schema Creates a new schema (.sf) file

Open File Opens and loads an existing schema

Save File Saves current schema with current file name (if there is 
none, Viewpoint Monitoring asks you to provide a file name)

Save As Saves current schema by specifying the file name

Save and View 
Schema

Saves current schema and then displays schema using the 
One-Line Viewer

Insert Device Inserts a device picture into the schema. This picture then 
can be connected and configured to a real device.

One Shot Test Provides a one-time reading of all the current values or 
status from each of the connected and configured 
components on the schema

Master Connect On Allows for but does not initiate connections to devices. Use 
One Shot Test or open the One-Line Viewer to initiate 
connections to devices.

Master Connect Off Disconnects all connected devices

 Zoom To zoom in and center the screen to the spot selected

 Zoom to Fit To zoom in to a magnitude that fits the entire schema layout 
on the screen

 Zoom to Selection To zoom in on the components selected

 Pan Moves the viewable area of the screen around the schema. 
To activate, select this tool and then place the hand icon 
over part of your schema. Click and drag the hand in a 
direction to move the schema.
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Align

Nudge

Structure

 Align Top Aligns the top sides of all the selected components to the top 
of the reference component

 Align Horizontal 
Centers

Aligns the horizontal centers of all the selected components 
to the horizontal center of the reference component

 Align Bottom Aligns the bottom sides of all the selected components to the 
bottom side of the reference component

 Align Left Aligns the left sides of all the selected components to the left 
side of the reference component

 Align Vertical Centers Aligns the vertical centers of all the selected components to 
the vertical center of the reference component

 Align Right Aligns the right sides of all the selected components to the 
right side of the reference component

 Nudge Up Moves selected component up one pixel

 Nudge Down Moves selected component down one pixel

 Nudge Left Moves selected component left one pixel

 Nudge Right Moves selected component right one pixel

 Group Combines all selected components into one entity

 
Ungroup Breaks apart all components of one entity into their 

respective original components
 Front Moves current components to the absolute front of all 

viewable layers
 Back Moves current components to the absolute rear of all 

viewable layers
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Rotate

Layout

Gauges
Before these gauges can measure real time values, you specify the device to connect 
the gauge to by double-clicking the gauge.

 Forwards Moves current components on layer higher than its original 
layer hierarchy

 Backwards Moves current components on layer lower than its original 
layer hierarchy

 Rotate Rotates selected component freely. Once selected, put your 
mouse cursor over the component and move the component 
clockwise or counter-clockwise.

 Rotate Left Rotates selected component 90 degrees counter-clockwise

 Rotate Right Rotates selected component 90 degrees clockwise

 Flip Vertical Flips the selected component on the vertical axis (left/right)

 Flip Horizontal Flips the selected component on the horizontal axis (up/
down)

 Space Across Evenly spaces the selected components across an 
imaginary horizontal axis, starting from the far left 
component and ending at the far right component

 Space Down Evenly spaces the selected components across an 
imaginary vertical axis, starting from the top component and 
ending at the bottom component

 Same Width Sets the width of the selected components to the same width 
as the reference component

 Same Height Sets the height of the selected components to the same 
height as the reference component

 Same Size Sets the width and height of the selected components to the 
same width and height of the reference component
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Symbols

 
Parameter Creates a generic analog reading component

 Bar 2D Creates a 2D bar gauge component

 Bar 3D Creates a 3D bar gauge component

 
Thermometer 2D Creates a 2D thermometer gauge component

 Thermometer 3D Creates a 3D thermometer gauge component

 Semicircle 2D Creates a 2D semicircle gauge component

 Segment 2D Creates a 2D segment gauge component

 Circle 2D Creates a 2D circle gauge component

 Semicircle 3D Creates a 3D semicircle gauge component

 Segment 3D Creates a 3D segment gauge component

 Circle 3D Creates a 3D circle gauge component

 Circle Multi Values Creates a multi-value circle gauge component

 Phasors Creates a phasor gauge component

 Bar Multi Values Creates a multi-value bar gauge component

 Automatic Voltage Regulator  Exciter

 Sectionalizer  Ground

 Test Switch  Bus Connection

 Capacitor 1  Bus End

 Capacitor 2  Generator

 Rectifier
 

Generator Synchronous

 Reactor  Motor
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Switch Gear and Control

 Resistor  Motor Synchronous

 Fuse  Motor Round Rotor

 Recloser
 

Turbine

Switch Ground

 Switch Motorized

 Test Switch 1

 Test Switch 2

 Switch Fused 1

 Switch Fused 2

 "V" Switch

 Send Command Can only be used to send out virtual inputs

Force Coil

 Circuit Breaker 1

 Circuit Breaker 2

 Drawout Breaker

 Custom Symbol 

 Switch Double Throw

 Contactor

 LED Indicator Analog and Digital types
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Transformers and Symbols

 Tapchanger  Transformer Voltage 1

 Transformer 1  Transformer Voltage 2

 Transformer 2  Transformer 5

 Transformer 3  Transformer Delta

 Transformer 4  Star

 Transformer AUTO  Zig Zag

 Transformer Phase Shifting  Star Grounded

 Transformer Current  Star Zig Zag Grounded
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Chapter 7: One-Line Viewer

One-Line Viewer

This chapter outlines use of the One-Line Viewer.
• View data
• Control devices
• Create screen captures
• Toolbar and buttons
• LED indicators
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Introduction
The One-Line Viewer displays data from the equipment and allows you to control 
devices. An example is turning a motor on and off. A schema diagram needs to be 
created first using the One-Line Editor (previous chapter). For the on/off example of a 
motor, a digital schema is created.
With the One-Live Viewer, you can view data, control the device, and take screen 
captures.
Files are saved in the .sf format.
The toolbar and buttons are explained at the end of the chapter.
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View data
To view data from a One-Line diagram:

1. In the main window of Viewpoint Monitoring, click the One-Line Viewer option to 
open the Viewer.

2. Open a file by clicking the Open File  button on the toolbar, or click File > 
Open and select the .sf file. 
Viewpoint Monitoring reads the values from the device and displays them. In the 
example shown here, Viewpoint Monitoring communicates successfully withe 
device, shown by the green LED indicator.

Figure 120: Successful communication with a UR device

3. If no data displays, check the LED indicator in the tab at the bottom of the window 
or by the Communication Status button at the top-right. These are explained at 
the end of the chapter and in the Interface chapter. Clicking the Communication 
Status button opens the Device Status window, which is outlined in the Device 
status section on page 43.

Figure 121: Parameter display
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Control devices
When viewing schemas, you can manually convert non-connected, digital components 
to their other state. An example is to switch a motor from ON to OFF. The schema 
diagram already needs to have the functions added as Switch Gear and Control 
buttons in the One-Line Editor.
You can also toggle between states, for example from ON to OFF then OFF to ON, for 
digital components.
If you click an inserted picture of a device, it opens the virtual front panel.
To control a device:

1. In the One-Line Viewer, select the digital component to be switched by clicking it 
once. The front panel of the device displays or the system prompts if you want to 
change the status of the symbol.

Figure 122: Prompt to change equipment status

2. Click the Yes button to confirm the change. The digital component switches to the 
opposite state.

To toggle the state:

1. Select the digital component to be toggled. A prompt appears.

Figure 123: Prompt to toggle state

2. Use both hands to issue the control command. In Viewpoint Monitoring, press and 
hold the Ctrl key (default) and simultaneously click the button with the state that 
you want the component to be in (for example, CLOSE or OPEN). If you just click 
the button without pressing the Ctrl key, nothing happens. If the state of the item 
being controlled is already set (that is, you send an OPEN command when the 
state is already OPEN), nothing happens.
The digital component that you have selected is switched to the required state.
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Create screen captures
Within the One-Line Viewer tool, follow these steps to take a screen shot of your 
current schema and place it on the Windows clipboard.
To create a screen capture:

1. In the One-Line Viewer, click Edit > Screen Capture. A copy of the active screen 
is placed on the computer clipboard. It excludes the menus and toolbars.

2. Paste the screen capture into a graphics program, such as the Paint or 
CorelDRAW.
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Toolbar and buttons
The figure shows the toolbar available in the View > Toolbar menu. Only the main 
System Viewer toolbar displays.

 Open File Opens a Viewpoint Monitoring schema file (.sf)

 Left arrow Jumps backward to previous schema, function, or application 
(only available for schemas that contain links)

 Right arrow Jumps forward to next schema, function, or application (only 
available for schemas that contain links)

 Master Connect On Allows for but does not initiate connections to devices

Master Connect Off Disconnects all connected devices
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LED indicators
An LED status indicator can display in the bottom tab and by the Communications 
Status button. Clicking the latter opens the Device Status window. The LEDs are 
explained as follows.

 Red At least one correctly configured device is not communicating

 Yellow All correctly configured devices are communicating but at least one 
analog or digital device on the schema is configured incorrectly

 Green All devices are communicating and configured correctly

 Grey Either no analog or digital device exists on the schema or all are 
configured incorrectly
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Chapter 8: Annunciator alarms

Annunciator alarms

This chapter outlines use of the Annunciator.
• Add alarm
• Acknowledge and reset alarm
• Delete persistent alarm
• Manage email notification
• Manage alarm sounds
• Toolbar and buttons
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Introduction
The Annunciator actively monitors measured values and generates alarms. Alarms 
can be configured for activation whenever a digital status changes state or whenever 
analog values change beyond a threshold.
The Annunciator allows visual, audio, and email notifications. The notifications can be 
recorded in the database for post-event analysis.
Use the Annunciator to create and view visual dashboards or alarm status screens to 
monitor and acknowledge the status of remote sites and devices.
Files are saved in the .ap format.
This chapter outlines the Annunciator window to set up alarms. Alarm sounds are 
configured under File > Preferences > Audible Alarms. To have the alarms that you 
set up in the Annunciator window run after you exit Viewpoint Monitoring, configure 
File > Preferences > Annunciator.
Alarms display automatically. If you close the Annunciator window and an alarm 
condition exists for a saved file, the Annunciator window launches automatically with 
the alarm.
The toolbar and buttons are explained at the end of the chapter.

Figure 124: Example of Annunciator alarms
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Add alarm
Each Annunciator panel can have up to 100 alarm indicators.
To add an alarm:

1. In the main window of EnerVista Viewpoint Monitoring, click the Annunciator 
option. The Annunciator window launches with an empty box.

Figure 125: Creating the first alarm

2. Click the Insert Indicator  button on the toolbar. This creates an alarm box in 
the empty box.

Figure 126: Alarm ready for configuration

3. Right-click the box and select Properties, or click the

Edit  button on the toolbar. The preferences window opens.
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Figure 127: Alarm setup window

4. Configure the Setup tab.
Display Name — The name of the indicator. Optional.
Device — The device to attach this indicator to.
Analog Parameters or Digital Parameter — Select one. You cannot configure 
both. Selects the alarm trigger. For a Digital Parameter, also select the Digital 
Item, which is a more specific trigger, such as a specific contact input.
Row and Col — The location of the indicator on the Annunciator panel, meaning 
the row and column. They cannot be edited. Use the Back and Next buttons to 
jump between alarms.

5. Configure the Active tab. The active options depend on the analog or digital 
parameters set in the previous tab.

Figure 128: Active configuration window
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Stay InActive — This option displays with selection of a digital parameter as a 
data item for the indicator. When enabled, there is no alarming for the parameter, 
which means that the Annunciator displays the value, it does not become 
alarmed, and the state displays as normal. In other words, the alarm remains 
inactive.
HIGH/LOW — This option displays with selection of a digital parameter as a data 
item for the indicator. An example is a digital output of 0 or 1. If you set the High 
option and the value 1 is read from the device, the alarm displays. If you set the 
Low option and the value 0 is read from the device, the alarm displays. An 
example is Virtual Inputs that can have a 0 or 1 value.

Figure 129: Digital parameter set

Value — The high and/or low conditions to trigger the indicator alarm. The 
following figure shows an example of an ambient temperature alarm being set 
between 5.1 and 27.5 degrees.

Figure 130: Setting high and low values for temperature

Latency Period — The amount of time that the value is in the alarm state before 
the alarm is triggered. The period is specified in milliseconds, where 3000 ms 
equals three seconds.

6. Configure the Colour tab. The active options depend on the analog or digital 
parameters set in the previous tabs. The fields are inactive when the alarm is 
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active; click the Acknowledge button at the top-right of the window.

Figure 131: Alarm color configuration window

Colour — Select the color to use on the Annunciator panel when the alarm is 
triggered. The Low color option is active when the trigger has a low trigger.

7. Configure the Audible tab.

Figure 132: Alarm sound configuration window

Play sound when active — Enable to sound an alarm when the indicator is 
triggered. Select the file to play. The .wav format is supported. If you specify other 
file types, such as an .mp3 file, the sound does not play. Disable to have no alarm 
sound when the indicator is triggered. Also specify if the sound is to be played 
Once or Repeated continuously until silenced.

8. Configure the EMAIL Notification tab. None, one, or more notifications can be 
sent. This feature supports only SMTP addressing; check configuration in the 
Annunciator tab under File > Preferences (see the Annunciator section on page 
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33).

Figure 133: Email notification configuration window

Normal -> Alarm — Enable to send an email message when the alarm is 
triggered.
Alarm -> Normal — Enable to send an email message when the alarm is no 
longer active and returns to a normal state.
On Acknowledge — Enable to send an email message when the alarm is 
acknowledged by clicking the Acknowledge button.
On Reset — Enable to send an email message when the alarm is reset by 
clicking the Reset button.
Email Address — Specify up to five email addresses to which the message is 
sent.

9. Configure the Reset tab.
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Figure 134: Reset configuration window

Manually reset — Returns the alarm to its original color when the Reset button is 
clicked.
Automatically reset — Returns the alarm to its original color when the alarm 
condition is removed and it returns to a normal state.

10. Configure the Hyperlink tab. This allows quick access to another annunciator or 
one-line diagram.

Figure 135: Hyperlink tab

Select the feature from the drop-down list. In this example, we link to a one-line 
diagram named "Water Treatment Plant.sf." When an indicator has an active 
hyperlink, the cursor changes from an arrow to a hand on user mouse-over. To 
navigate to the hyperlink, the user double-clicks the indicator. The following figure 
shows what the view looks like when the user right-clicks the Properties. Note the 
option for one-line diagrams to open the hyperlink destination in a new tab.
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Figure 136: End-user accesses hyperlink properties

11. When all tabs have been configured, click the OK button to save and exit. The 
alarm has been configured and text reflects configuration. The default color of the 
box is white; this cannot be configured. The "normal" indicates that the alarm is 
not triggered.

Figure 137: Configured alarm on Annunciator panel

12. Save the file, the format for which is .ap.
13. Add additional alarms/alerts as needed and configure them. Up to 100 are 

possible per Annunciator panel. To add another panel, click File > New.
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Acknowledge and reset alarm
When a configured alarm is triggered, the information appears in the Annunciator 
panel, for example the alarm flashes red when configured as such, displays "ALARM," 
and information appears at the bottom of the window.
To fix an alarm:

1. Select the alarm box.
2. Click the Acknowledge button at the top-right of the window. The alarm stops 

flashing.
3. When the alarm reset mode was set to Automatically reset, the alarm resets, 

returns to a "normal" state and the default white color displays, provided that the 
indicator is no longer in the alarm state.
When the alarm reset mode was set to Manually reset, click the Reset button at 
the top-right of the window. The alarm resets, returns to a "normal" state, and the 
default white color displays, provided that the indicator is no longer in the alarm 
state.

In the example shown here for the online/offline state of a device, the Acknowledge 
button was clicked and the Reset button needs to be clicked (message at bottom of 
window). The device has come back online (green LED for Communication Status), 
but the alarm still needs to be cleared by pressing the Reset button. Upon reset, the 
alarm box is white and displays the "normal" state. If the alarm condition still exists, 
this does not clear the alarm.

Figure 138: Alarm for online/offline status of device
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Delete persistent alarm
If you delete an alarm and it continues to activate, delete the .ap alarm file, exit the 
software, and restart the computer.
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Manage email notification
Emails can be sent when alarms are triggered, acknowledged, reset, and/or returned 
to a normal state. Configuration is done in the following two places:
• EMAIL Notification tab when configuring an alarm (outlined earlier in this 

chapter)
• File > Preferences > Annunciator (see the Annunciator section on page 33)
To view who receives email notification for an alarm:

1. Right-click the alarm and select Notification Report.
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Manage alarm sounds
Alarm sounds can be triggered. Configuration is done in the following two places:
• Audible tab when configuring an alarm (outlined earlier in this chapter)
• File > Preferences > Audible Alarms (see the Audible alarms section on page 32)
Use the Mute Sound button at the top-right of the window to turn off sound. This does 
not affect the alarm itself.
The button toggles from sound on  to sound off .
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Toolbar and buttons
A single toolbar displays in the Annunciator window. There are no optional toolbars.

 New Creates a new annunciator panel file (.ap)

 Open Opens/loads an existing annunciator panel file (.ap)

 Save Saves current .ap file with existing file name. If a file name has not 
been specified, ViewPoint Monitoring prompts you to name it.

 Save As Saves current .ap file with a new file name

 Edit Edits the selected alarm

 Insert Indicator Inserts an alarm box that can be configured

 Cut Copies and removes the current selected alarm box and places it 
on the Windows clipboard

Copy Copies the current selected alarm box and places it on the 
Windows clipboard

Paste Pastes the current selected alarm box that is on the Windows 
clipboard

Delete Deletes the selected alarm

 Master Connect 
On

Allows for but does not initiate connections to devices

Master Connect 
Off

Disconnects all connected devices
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Events

This chapter outlines use of event records.
• Enable or disable event recording
• View events
• Filter events
• Change event type
• Delete event
• Toolbar and buttons



144 ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL

INTRODUCTION CHAPTER 9: EVENTS

Introduction
Event records can be viewed for Viewpoint Monitoring and devices. Entellisys and 8 
Series devices do not support Events and Waveform retrieval using a serial interface.
As enabled per-device, the event records from devices are downloaded automatically 
and stored in the database, creating system-wide sequence of event records. When 
the Events check box is enabled in the Device Setup window for a device, Viewpoint 
Monitoring continuously polls the device to see if any events have been detected, 
downloads the event records, and stores them.
Event entries are color-coded and can be filtered.
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Enable or disable event recording
Configuration was done when adding a device, and it can be changed at any time.
To have events retrieved from devices after you exit from Viewpoint Monitoring, 
configure the Waveform, Events, Time Download tab under File > Preferences.
To enable or disable event recording for a device:

1. In the main window of Viewpoint Monitoring, click the Device Setup option. The 
window launches.

2. Access the device.
3. Enable or disable the Events check box.
4. Click the OK button to save and exit.

Figure 139: Device configured to allow event record retrieval
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View events
To view events:

1. In the main window of Viewpoint Monitoring, click the Events option. The window 
launches, which is actually a separate application.
Within the application, the window can be relaunched by clicking the Sequence 
Of Events button on the left side of the toolbar.

Figure 140: Event viewer

Examples of the messages displayed in the Event column are as follows.
Force Coil ’Clear Data Logger’ Sent FAIL — A command to clear the data log was 
initiated from the one-line schema by the user, but it failed.
Panel: ALARM (high) Accumulator (DC 1), 55022 — The accumulator value, at 
55022, triggered an alarm that was set up by the user in the Annunciator panel.
Device is Dead — The device went offline, for example lost power or was unplugged.
Net 2 ... Device ACTIVE — The device came online, for example regained power.
Panel RESET (PASSED). Communication Status On — An alarm was triggered, 
acknowledged, and, specifically, the Reset button was clicked and all is okay with the 
device.
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Filter events
Event entries are color-coded and can be filtered. The window also can be configured 
to display only the events wanted.

Configure events displayed
To configure which events display:

1. Click the Seq. Config  button on the toolbar. The window opens.
2. Enable and disable the appropriate check boxes of the event types in the window. 

The System Events, ViewPoint Events, and ViewNode Events are for Viewpoint 
Monitoring. To view only events for devices, disable these three options.

3. Click the Ok button to save and exit.

Figure 141: Configure events displayed

Filter events
To filter events:

1. Click the View menu and select an option. Or click one of the filtering buttons on 
the toolbar, such as Device Events, Alarms, System, Waveforms, or 
Unacknowledged Alarms.
A new window opens with the filtered events. The window is blank where there 
are no event entries.
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Change event type
Events can be changed to alarms and vice-versa.
To change an event type:

1. In the event record window, select an event.
2. Right-click the event, select ChangeEvent Type, and select Event or Alarm.
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Delete event
Entries can be deleted.
To delete an event:

1. In the event record window, select an event.
2. Right-click the event and select Delete. The entry is deleted. The entry needs to 

be selected in order for it to be deleted; if another entry is selected instead of the 
one that you want to delete then the incorrect entry is deleted.
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Toolbar and buttons
A single toolbar displays in the Events window. There are no optional toolbars.

Sequence of Events Displays all events

 Device Events When the device is powered on or off, plus firmware version

 Alarms Any active alarms. Blank when none.

System When Viewpoint Monitoring detects events for the device, 
such as the device going offline or online, for example 
because an alarm was triggered

Waveform Any active waveform events. Blank when none.

Annunciator

Fault Reports

Seq. Config To select the types of event records to display and to select 
the columns that display in the table

HMI Device Types

Unacknowledged 
Alarms

User-Defined 
Events

Enables Refresh

Disables Refresh

Display Query 
Results

About Displays the version number of the Event viewer, which is a 
separate application launched from Viewpoint Monitoring.
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Trending Reports

This chapter outlines use of reports.
• Add report
• Quick add report
• View report
• Change report and parameters
• Print chart
• Export chart
• Archive report
• Automatic backup and purge
• Delete report or chart
• Purge report data
• Toolbars and buttons
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Introduction
Trending reports are used to archive data for devices. They record the values of 
monitored analog and digital points, with one-minute resolution. The data stored in the 
reports is viewable as graphs and tables.
EnerVista Viewpoint Monitoring from v7.2 and above uses a database instead of the 
flat files (.REP) used with EnerVista Viewpoint Monitoring prior to v7.2. Legacy .REP 
files are supported in a view mode and can be converted to the database. Any reports 
available for conversion are listed in a .RPC Reports
Configuration files reside in the C:\Program Data\EnerVista\Viewpoint Monitoring\My 
Documents\reports folder. Database Reports support all functionality available in the 
previous Viewpoint Monitoring versions. The method for calculating daily and hourly 
averages also was changed, allowing more precise averaging. This explains any 
noticeable deviation when comparing an old flat file report and new database reports.
Reports are stored in the table ReportData in the local database, meaning the 
PMCSSQLSERVER12 database that is used for storing events from devices. The 
ReportData table has ChannelID, Time, and Data columns, where ChannelID 
corresponds to ParameterID, Time is a timestamp, and Data is the polled value of the 
data point.
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Add report
A maximum of 100 reports can be created and run concurrently, with a maximum of 50 
parameters in each report and a maximum of 50 charts in each report.
To add a report:

1. In the main window of Viewpoint Monitoring, click the Trending Reports option. 
The window opens.

2. Click the Add button. The properties window opens.

Figure 142: Enter name of report

3. Configure the General tab.
Report Name — The name of the report.
Description — Optional description of the report.

4. Configure the Parameters tab. If the report is running, stop it by clicking the Stop 
button in the Trending Reports window before accessing the properties window.
Click the Add button. The window opens. If the button or fields are not active, stop 
the report as outlined.
Name — The name of the parameter.
Color — The color of the parameter, for example on the chart.
Device — The device to read data from.
Analog Parameter or Digital Parameter — Select one or the other.
Digital Item — Select the specific items for a digital parameter.
Click the OK button to save and exit. Use the up and down arrows to arrange the 
order.



154 ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL

ADD REPORT CHAPTER 10: TRENDING REPORTS

Figure 143: Adding parameters to a report

5. Configure the Charts tab; click the Add button. A maximum of 50 charts can be 
configured for each report.
Chart Name — The name to appear at the top of the chart or table along with the 
report name, for example Report 1 - LED Test.
Description — Optional information that does not appear on the chart or table.
Show — Enable to show the parameter on the chart or table.
Show Zero — When enabled, the base of the graph is always 0.

Figure 144: Base of graph at 0 

Show High/Low — Enable to draw separate lines on the graph to indicate the 
High and Low values when averaging is used to plot values. The graph is 
vertically axed between the high and low values; the 0 base value does not 
display unless it is part of the high/low range.
Reference Lines — Draws a line on the chart grid, for example a red line at 0.500 
horizontally across the graph. Each reference line is defined by a name, value to 
graph the line, and the color to plot the reference line. Up to 10 reference lines can 
be added to each chart.



CHAPTER 10: TRENDING REPORTS ADD REPORT

ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL 155

Figure 145: Chart configuration window

6. Click the OK button to save and exit, then again. A window asks if you want to 
start the report. If the answer is Yes, Viewpoint Monitoring records each minute 
the value for the parameters configured in the report. The values are stored in the 
database, and they can be exported to a file in comma-delimited format that can 
be imported into Microsoft Excel. If No, data is not recorded.

Figure 146: Prompt to create report

7. Save the report under File > Save. The file is saved in a .sf format; you are not 
saving individual reports in the .rep format.
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Quick add report
Use the Quick Add button to duplicate an existing report with parameters from only
one device.
To duplicate a report:

1. In the main window of Viewpoint Monitoring, click the Trending Reports option. 
The window opens.

2. Click the Add button. The report quick add window opens.

Figure 147: Select single device report to duplicate

3. Select a single device report and click OK. Click Yes to confirm, and the report is 
duplicated.
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Figure 148: New report

4. If any changes are required, edit as for a new report in the previous Add report 
section.
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View report
The chart must be configured and enabled before display (previous section). You 
launch the chart, then can switch to a table view, as well as change the time period 
used to display the chart.

Figure 149: Example of chart

Reports are listed automatically when opening the Trending Reports application; you 
do not need to manually open a file. When a report is not running, it is listed with a 
lighter font. In the example shown here, two reports are inactive and one is active.

Figure 150: Two reports not running

To start a report, select the entry, and click the Run button. If the button does not 
display, it means that the report is already running.
There are report status indicators show after the Run button is pressed:
• Communicating - if the report is communicating with the device and the data is 

recorded, the status column of the report will display a checkbox with a green 
checkmark.



CHAPTER 10: TRENDING REPORTS VIEW REPORT

ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL 159

• Not Communicating - if no parameters are read from the device, meaning that 
there is no communication from the devices in the report, then the status column 
will display a checkbox with a red cross.

• Communication Errors - if only some of the parameters from the report are read, 
which could happen if some of the parameters are from different devices, the 
status checkbox will have a yellow cross.

To view an archived report, click File > Open, and select the .rep file to open it.
To view a chart in a report, select the chart from the Select chart drop-down list in the 
View column of the Trending Reports window. The pre-configured chart opens.

Figure 151: Displaying a report chart

To view a table, click the table icon .

Change time period in chart
Data points are sampled constantly and an average for a data point is calculated every 
minute.
In order for the data to display properly, the size of the date window determines the 
format of the data displayed. The following rules govern how the time range displays:
• If the date window is less than one day, the minute data are charted
• If the date window is greater than one day and less than two months, each data 

point is the average for an hour. There is an option to show the High/Low range on 
the same graph.

• If the date window is greater than three months, each data point is the average for 
a day. There is an option to show the High/Low range on the same graph.

The High/Low range is based on the highest and lowest stored minute samples.
To change the time period in a chart:

1. Open the chart as outlined.
2. Select the period from the Date Selector drop-down list or change it in the From 

and To fields. The period is not saved, even when you save the report; you select 
the period each time that you access the chart.

Figure 152: Selecting time period to display
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Change report and parameters
Starting from Viewpoint Monitoring 7.10, parameters can be added to existing reports 
that were already run. You can also add parameters from other reports, existing and 
running for a while. The data previously accumulated in these reports can be viewed in 
the report to which the parameters were added.
Once set, default values can be changed in the reports and chart windows.
To change the parameters:

1. In the Trending Reports window, double-click the entry. In the chart window, click 
the

Preferences  button on the toolbar. The window opens.
2. Configure as outlined.
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Print chart
Charts can be printed or saved to an output format supported by your computer, such 
as PDF.
To print a chart:

1. Open the chart as outlined.

2. Click the Print  button on the toolbar.
3. Choose to print to a printer or save to an output format such as PDF.
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Export chart
Charts for a specific time period and frequency can be exported in .csv format, which 
can be opened in Microsoft Excel. In order to export a chart, device communication/
connection is not required. The export will only export the data that is already recorded 
in the SQL database. 
Charts can be exported from either the Trending Reports or Chart windows, both 
outlined below.

Trending Reports window
To export a chart in the Trending Reports window:

1. Select the required report/chart.

Figure 153: Select the report/chart to export

2. Click the Export button at the top of the window. The following window opens.

Figure 154: Export button

3. Select the time period and frequency to export, and check the file name and 
location for the export. If the fields are inactive, the report has not been run in 
order for it to be exported.
Show Min/Max — This check box is active when the Frequency selected is other 
than “Minute samples”. Enable the check box to export the minimum and 
maximum hourly or daily averages.
Clicking the left arrow button sets the start date to the oldest date recorded in the 
report. Clicking the right arrow button sets the last date recorded in the report.

4. Click the Ok button to export and exit. In the following figure, the --- values 
indicate time in the future so no readings have been reported.
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Figure 155: Example of report in Excel

Chart window
To export a chart in the Chart window:

1. Click the Export  button on the toolbar.
2. Select the time period to export, the frequency to export, and check the file name 

and location for the export. If the fields are inactive, it means that there is a 
problem communicating with the device; the Status needs to be good in the main 
window.

3. Click the Ok button to export and exit.
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Archive report
Reports, meaning the data and charts, can be manually archived. The data is saved 
from the database into the .rep format. The next section outlines automatic backups.
The default location is 
C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents\reports\
To manually archive a report:

1. In the Trending Reports window, select the report.
2. Click the Archive button. The window opens.

Figure 156: Archiving chart data for a report

3. Specify the time period, and check or specify the file name and location for the 
archive.
Clicking the left arrow button sets the start date to the oldest data recorded in the 
report. Clicking the right arrow button sets the end date to the last date recorded 
in the report.
If the start date selected is the start of the report data, the software prompts if you 
want to purge the data after the archiving is completed.
If the report contains Parameters shared with other reports, the software prompts 
if shared channels are to be purged.

4. Click the Ok button to archive and exit.
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Automatic backup and purge
Starting from ViewPoint Monitoring 7.10, a feature was added to the reports: 
Automatic Backup and Purge. This purge function is not the same as the Purge Data 
outlined later.
Automatic backup and purge is performed every day at midnight, after reaching the 
Preferred Maximum of days set in Preferences. Backup data is saved to 
"C:\ProgramData\EnerVista\Viewpoint Monitoring\My Documents\reports\Backup\ 
ReportData_YYYY_MM(n).csv" files, where n is a zero-based index, indicating 
number of files in a month. After creating a first file, at the beginning of each month 
new portions of data are appended to the end of the existing file every day up to the 
end of the month. Unless the CSV file reaches maximum size of 100 MB, only one 
CSV file is created monthly. If the file exceeds maximum size, a new file for that month 
is created.
There are no instructions for backup and purge, which are performed automatically 
every day at midnight.
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Delete report or chart
If a report appears inactive in the window, it means that its file is not running or it has 
been deleted. You can still click into the entries and save them.

Figure 157: Inactive reports when file not found

To delete a report:

1. In the Trending Reports window, select the report.
2. If the Delete button is not active, click the Stop button.
3. Click the Delete button, and confirm the deletion.
To delete a chart:

1. In the Trending Reports window, double-click the report. The properties window 
opens.

2. Click the Charts tab.
3. Select the chart.
4. Click the Delete button, and confirm the deletion.
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Purge report data
Report data can be manually deleted. This differs from the Automatic Backup and 
Purge function outlined earlier.
Purging of data always begins with the oldest data, which is found at the beginning of 
the report.
To purge report data:

1. In the Trending Reports window, select the report.
2. If the Purge button is inactive, click the Stop button
3. Click the Purge button. The window opens. The left arrow button is inactive 

because purging is done starting from the oldest data recorded in the report.

Figure 158: Deleting oldest data from report

4. Check the end period in the To field. Clicking the right arrow button sets the end 
date to the last date recorded in the report, which is selected by default when the 
window opens.
If the report contains Parameters shared with other reports, the software prompts 
if shared channels are to be purged.

5. Click the Ok button to purge, confirm the purge, and exit. If there is no data to 
purge, a message displays to this effect. The report needs to be started again to 
generate new data.
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Toolbar and buttons
The following toolbar and buttons display in a chart window.

Open Opens an archive report file in the .rep format

Preferences Opens the window to configure the chart

Export Exports the chart data as an Excel spreadsheet in the .csv 
format 

Print Outputs the chart to a printer, a PDF file, or other formats 
supported by the computer

Left Arrow Button The Left Arrow Button is used to return back to the larger 
time range graph.
When viewing a graph that displays the time in days, click 
that day in the graph to display the hours of that days in a 
graph. Similarly, when viewing a graph that displays the time 
in hour, click that hour in the graph to display the minutes of 
that hour in a graph.

Chart Button Displays the data in a 2D graph

Table Button Displays the data in a table

Date Selector Select one of the Report's predefined charts. Selecting from 
the Date Selector drop-down list initializes the Date Window 
to the specified date range. Options for the Date Selector 
are:

Current Hour
Last Hour
Today
Last 24 Hours
Yesterday
Current Week (M-S)
Current Week (S-S)
Last 7 days
Current Month
Last 30 days
Current Year
Custom Date

Date From ... To To select a custom time range to view the data. Simply 
select the start and end time in the Date Window From and 
Date Window To drop-down boxes. When the user edits 
these drop down boxes, the Date Selector drop-down box 
displays "Custom Date." The user must then click the right 
arrow button to display the Custom Date in the viewer.

Right Arrow Button Select a custom date with the Date Window From and Date 
Window To drop-down boxes, then click the right arrow 
button to display the time range in the viewer
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Waveforms

This chapter outlines use of waveform diagrams and COMTRADE files.
• View demonstration files
• View COMTRADE file
• View phasors
• View harmonics
• Convert waveform to COMTRADE file
• Merge COMTRADE files
• Resample COMTRADE file
• Toolbar and buttons
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Introduction

Waveform files
When enabled in Viewpoint Monitoring for a device, waveform (oscillography) files 
from GE Vernova Grid Solutions devices are downloaded automatically from the 
device and stored on the computer hard drive. When a new waveform is detected, the 
file is downloaded to the hard drive.

Figure 159: Waveform files can be downloaded automatically from GE devices

Waveform files from third-party devices are not supported. They cannot be 
downloaded from a third-party device or viewed in Viewpoint Monitoring.
Entellisys and 8 Series devices do not support Events and Waveform retrieval using a 
serial interface.

COMTRADE files
The Common Format for Transient Data Exchange (COMTRADE) is a file format for 
storing waveform, status, and fault data. The format is an IEEE standard, specifically 
C37.111.
Viewpoint Monitoring supports the C37.111-1991 and C37.111-1999 COMTRADE 
standards. As such, four file types can be generated, as follows:
• Header (.HDR)
• Configuration (.CFG; required)
• Data (.DAT; required)
• Information (.INF)
Support for COMTRADE files means that they are viewable in Viewpoint Monitoring. 
The COMTRADE viewer feature within Viewpoint Monitoring provides a visual display 
of power systems data and relay operational data captured during a specific triggered 
event.
Previously captured and saved waveform/oscillography COMTRADE files (.CFG) can 
be viewed while offline. Oscillography data has to be first extracted from a device while 
online, but once extracted, the data can be saved to disk. Any .CSV files retrieved 
from GE Vernova Grid Solutions products can be combined with existing COMTRADE 
files and viewed within a single window. These files can then be opened in Viewpoint 
Monitoring and allows the user to analyze the captured waveforms.
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Figure 160: Selection window for waveforms
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View demonstration files
Demonstration waveform files can be viewed.
As documented in the IED Dashboard chapter, these and other files can be imported 
into the software and customized for use.
To view demo files:

1. In the Control Panel for Windows, change the Folder Options so that hidden files 
and folders show.

2. In the main Viewpoint Monitoring window, click File > Open and open the 
following file as an example:
C:\ProgramData\EnerVista\Viewpoint Monitoring\My 
Documents\Examples\OVERCURRENT.cfg
or when using a UR device
C:\Program Files (x86)\GE Power 
Management\URPC\Data\Demo\OVERCURRENT.cfg
Note that other .cfg files for viewing are located in the same directory.

3. When done, turn off hidden files and folders.

Figure 161: Demonstration file
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View COMTRADE file
The viewer provides a visual display of power systems data and relay operational data 
captured during a specific triggered event. It can display oscillography, phasors, 
harmonics, and actual values retrieved from the COMTRADE file.

Figure 162: COMTRADE file displayed in Viewpoint Monitoring

Files can be viewed that were downloaded automatically by Viewpoint Monitoring or 
that are available separately. Both methods are documented here. The toolbars and 
functions are explained at the end of the chapter.
The device needs to be configured in the Device Setup window to allow waveform 
retrieval. The Waveform option needs to be enabled.
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Figure 163: Device configured to allow waveform retrieval

To view a COMTRADE file that was downloaded automatically:

1. In the main window of Viewpoint Monitoring, click the Waveforms option. The 
selection window opens.

2. Click the upper View option to open files that were downloaded automatically by 
Viewpoint Monitoring. If there are no such files to open, a message appears to 
that effect, and then a window displays to open an existing waveform file in the 
.cfg format.

To view all other COMTRADE files:

1. In the main window of EnerVista Viewpoint Monitoring, click the Waveforms 
option. The selection window opens.

2. Click the lower View option. A window opens.
3. Select the .cfg file to open.
The interface is explained at the end of this chapter.

Set preferences
Up to 40 channels can be plotted in various colors, line styles, and groups for 
simultaneous display. These 40 channels can be a combination of analog and digital 
channels. Phasors can only be set up to the number of analog channels being used. 
For example, if 20 Analog channels are enabled, 20 Phasors channels can be used.
Other than the preferences outlined here, to have waveforms retrieved from devices 
after you exit from Viewpoint Monitoring, configure the Waveform, Events, Time 
Download tab under File > Preferences.
To set preferences:

1. With the waveform file open, click the Preferences  button on the toolbar. The 
window opens.
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Figure 164: Configuring the waveform view

2. Complete the General panel. Use this panel to add comments to a COMTRADE 
file, display channel names, alter the window transparency, and choose a 
background color. These changes effect the display of the Oscillography, Phasor, 
and Harmonics screens.

3. Complete the Analog Channels panel.
Channel — Displays the name of each channel/waveform. Read-only.
Color — Click the color to change the displayed color for that channel.
Scaling — Allows for channels to be grouped so that they share the same scale.
Line Style — Selects the format of the displayed line for that channel.
Graph — Enable to display the channel on the waveform graph.
Phasor — Enable to display the channel on the phasor graph.
FFT — Enable to display the channel on the harmonic graph.
Optionally customize the Phasor display of the analog channels with the following 
options.
Select Reference — Allows the selection of an analog channel to be used as a 
zero phase angle reference for the phasor graph. If None is selected, the absolute 
channel magnitudes and phase angles are plotted according to the position of 
cursor 1.
Maximum harmonic to calculate — 
Samples/Cycle — For proper display of the phasor angle(s), enter the sampling 
rate for the data points of the COMTRADE file. Phasors are incorrect if an 
incorrect value is specified for the samples/cycle.
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Figure 165: Analog Channels panel

4. Complete the Digital Channels panel.
Channel — Displays the name of each channel/waveform. Read-only.
Change Detected — A check mark is generated when a change of state is 
detected.
Color — The color displayed for that channel on the waveform.
Line Style — The format of the displayed line for that channel.
Graph — Enable to display the channel on the waveform graph.

Figure 166: Digital Channels panel

5. Complete the Symmetrical Components panel. This panel allows the symmetrical 
components to be calculated and shown for a three-phase system.
Channel — Displays the name of each channel/waveform. Read-only.
Scaling — Allows for the channels to be grouped so that they share the same 
scale.
Phase A — Phase A component to be used.
Phase B — Phase B component to be used.
Phase C — Phase C component to be used.
Colors — The colors displayed for channel phases on the waveform.
Phasor — Enable to display the channel on the phasor graph.
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Figure 167: Symmetrical Components panel

6. Click the Ok button to save and exit.
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View phasors
A Phasor diagram indicates the rotation, magnitude, and angle with respect to a 
selected reference component chosen in the Preferences window.
A Phasor diagram is viewed simultaneously with the oscillography waveforms and can 
be resized. By either dragging the cursor or clicking the play button, the Phasor 
diagram updates the position of the cursor based on the playback rate.
Clicking an icon on the toolbar opens the Phasor window.
To open the phasor window:

1. With the waveform/COMTRADE file open, click the Phasor  button on the 
toolbar. The window opens. The actual values for the phasor quantities, such as 
amplitude and phase angle, display in the Magnitude/Angle column.

2. Click the Play  button on the main toolbar (not the Phasor window).
3. In the oscillography window, click and drag the vertical green line left, for example, 

to change the display.

Figure 168: Phasor window

The interface is explained at the end of this chapter.
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View harmonics
The Harmonics table lists the calculated percentage of total harmonic distortion (THD) 
due to each phase. The Preferences window can be used to change which values 
display and the colors.
The harmonic spectrum is viewed simultaneously with the oscillography waveforms. 
Clicking an icon on the toolbar opens the window. The window can be resized.
To open the harmonics window:

1. With the waveform/COMTRADE file open, click the Harmonics  button on the 
toolbar. The window opens.

2. Click the Play  button on the main toolbar (not the Harmonics window).
3. In the oscillography window, by either dragging the green line or clicking the 

Cursor 1 or 2 button, the diagram updates to the corresponding position of the 
cursor.
The table lists the calculated percentage of THD due to each phase.

Figure 169: Harmonics window
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Convert waveform to COMTRADE file
This function converts a CSV oscillography file into a COMTRADE file viewable by the 
COMTRADE viewer within Viewpoint Monitoring. GE Vernova Grid Solutions products 
that create CSV oscillography files include 369PC, 469PC, 489PC, 745PC, 750/
760PC, PQMPC, and PQMIIPC.
If converted into an ASCII data file, an oscillography COMTRADE (.cfg) file can be 
readable by spreadsheet applications.
You specify the CSV file, the name for the resulting COMTRADE file, and configure 
the COMTRADE file.
Waveform files from third-party devices are not supported.
To convert a CSV file to a COMTRADE file:

1. In the main Viewpoint Monitoring window, click the Waveforms option. The 
selection window opens.

2. Click the Convert option. The window opens.
3. Complete the fields.

Figure 170: Converting a file

Select Source CSV File — Click the ... browse button and select the .csv file to 
convert.
Select Destination COMTRADE file — Enter the name and destination of the 
output file. Use the ... browse button to navigate.
Format of COMTRADE Data file — Select ASCII to save the files in a text format 
and view them as a spreadsheet. Select Binary to save smaller files that are 
viewable only in the COMTRADE viewer.
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CT Configuration — Specify the current transformer (CT) ratios for the phase 
and ground CTs for the current channels. The CSV file displays only Primary 
values, but COMTRADE has support for displaying current information in either 
Primary or Secondary quantities. Locate this information for a GE device in its 
EnerVista software under Settings > System Setup > AC Inputs > Current. (This 
displays the values, not the ratio.)
VT Configuration — Specify the voltage transformer (VT) ratio for the voltage 
channels. The CSV file displays only Primary values, but COMTRADE has 
support for displaying voltage information in either Primary or Secondary 
quantities. Locate this information for a GE device in its EnerVista software under 
Settings > System Setup > AC Inputs > Voltage.
Line Frequency — Specify the line frequency at which the CSV information was 
recorded. The line frequency is the frequency for electrical currents and plugs 
used in countries, which is 60 Hz in North America and 50 Hz in Europe, for 
example. Electrical line frequency by country can be looked up on the Internet.
Open in COMTRADE Viewer — Enable the check box to view the COMTRADE 
file after it is created. Disable to convert the file and not view it.

4. Click the Convert button in the window to convert and exit. If the file is a .csv file 
but not a waveform file, a message appears to that effect. With conversion, a 
.CFG file results. When the option to open the file is selected, the viewer 
launches.
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Merge COMTRADE files
The convert utility converts a CSV oscillography file into a COMTRADE file viewable 
by COMTRADE viewer. If converted into an ASCII Data file, an oscillography 
COMTRADE (.cfg) file is readable by spreadsheet applications. Such files can be 
merged.
To merge CFG files:

1. In the main Viewpoint Monitoring window, click the Waveforms option. The 
window opens.

2. Click the Merge option. A wizard opens.
3. Complete the fields.

Figure 171: Merging files

Select 1 or 2 COMTRADE files — Click the ... browse button and select the .cfg 
files to merge. The first COMTRADE file entered in the list is considered the 
reference file, which determines the start time and trigger time of the merged file.
Select Destination COMTRADE file — Enter the name and destination of the 
output file. Use the ... browse button to navigate.
Format of COMTRADE Data file — Select ASCII to save the files in a text format 
and view them as a spreadsheet. Select Binary to save smaller files that are 
viewable only in the COMTRADE viewer.
Click the Next button. The wizard advances.

4. Complete the fields.
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Figure 172: Analog channels

On the left side are the available waveforms from both source COMTRADE files. 
On the right are the selected waveforms for the destination COMTRADE file. 
Highlight the required waveforms from the source files and use the single right 
arrow button to move it to the destination file. Or use the double right arrow button 
to move all the waveforms from the analog list to the destination file. 
To remove any incorrectly selected waveforms from the destination list, use the 
trash can icon. The up and down buttons are provided for re-ordering the analog 
list of the destination file. 
Click the Next button. The wizard advances.

5. Complete the fields, this time for digital channels.

Figure 173: Digital channels

Click the Next button. The wizard advances.
6. Complete the fields.
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Figure 174: Sample rate

At the top of the window are four boxes detailing the start and end times of the two 
source COMTRADE files. If synchronization is required, the Trigger in the 
second file lagging by field is given to add an offset to the second file. This offset 
can be negative, in which case the first file lags the second file.
Destination - Sample Rate — Enter the resample rate in Hertz. The default value 
is 3840 Hz. This is the rate for the destination file. You know the original sampling 
rate from computer software settings, for example 64 samples/cycle.
Open in COMTRADE Viewer — Enable the check box to view the COMTRADE 
file after merging. Disable to merge the file and not view it, or if you are generating 
ASCII files.

7. Click the Ok button. The two source COMTRADE files are merged into the 
specified destination file. If three or more files are to be merged, this process can 
be repeated using the destination file from the first merge as one of the source 
files for a second merge.
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Resample COMTRADE file
Sampling refers to the data collected. Sampling rate is the frequency at which the data 
is collected. For COMTRADE files, the sampling rate is specified in Hertz (Hz). 
Resampling takes a subset of the sample data collected.
Resampling a COMTRADE file allows you to convert a COMTRADE file with a 
variable sampling rate to a COMTRADE file with a fixed sampling rate. Additionally, a 
fixed sampling rate of a COMTRADE file can be changed to a new value.
To resample a COMTRADE file:

1. In the main Viewpoint Monitoring window, click the Waveforms option. The 
selection window opens.

2. Click the Resample option. The window opens.
3. Complete the fields.

Figure 175: Changing the sampling rate

Select Source COMTRADE file — Click the ... browse button and select the .cfg 
file to resample.
Select Destination COMTRADE file — Enter the name and destination of the 
output file. Use the ... browse button to navigate, for example to select the existing 
file and change its name, for example to "_new."
Format of COMTRADE Data file — Select ASCII to save the files in a text format 
and view them as a spreadsheet. Select Binary to save smaller files that are 
viewable only in the COMTRADE viewer.
Destination - Sample Rate — Enter the resample rate in Hertz. The default value 
is 3840 Hz.
Open in COMTRADE Viewer — Enable the check box to view the COMTRADE 
file after it is created. Disable to resample the file and not view it.

4. Click the Resample button in the window to resample and exit. When the option 
to open the file is selected, the viewer launches. A .cfg file, a .dat data file, and a 
.hdr header file are generated.
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Toolbar and buttons
This section explains the waveform viewer and the phasor window.

Toolbar

Waveform functions

 Open Opens/loads an existing COMTRADE file (.CFG)

 Save Saves current .CFG file with existing file name. If a file name has not 
been specified, the software prompts you to name it.

 Print Prints the waveform

 Preferences Opens the COMTRADE Viewer preferences window

 Data Shows the actual value of the waveform at the specified cursor 
position

 Phasors Shows the phasor diagram of the waveform at the specified cursor 
position

 Harmonics Shows the harmonic spectrum of the waveform at the specified 
cursor position

 Play Begins moving the first cursor through waveform samples at the 
specified sampling rate.
During playback, the Phasors screen and Harmonic screen also are 
updated accordingly in real time based on the position of cursor 1.
The playback automatically rewinds and repeats when the end of 
oscillography record is reached.

 
Stop Stops moving the first cursor through the waveform; stops the 

waveform
 Zoom out Zooms out from the previous selected scale.

A selected section of waveform(s) can be zoomed in on by right-
mouse clicking and dragging the outline box over the desired 
segment. Multiple zooms are possible.
Waveforms can be super-imposed on top of each other by selecting 
and dragging them with the left mouse button.
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Phasor window
Use the Preferences window in the COMTRADE window to change the values 
displayed, the number of phasors, and the colors.

Selects between cursor positions.

Phasor magnitude view attributes are set by highlighting the following options.
Peak versus RMS — Select between peak and root mean square (RMS) phasor 
magnitudes.
Primary versus Secondary — Select between the primary or secondary phase 
voltages.
Scaled versus Fixed — Select between scaled phasors or fixed magnitude phasors. 
Fixed magnitude phasors ignore the magnitude value and only show the angles.

vertical red 
line

Indicates the trigger position (%) of the data capture

blue and 
green vertical 
lines/cursors

Indicate initial time and final time. Can be moved either by clicking 
and dragging them left and right across the duration period of the 
signal, or by using the Cursor 1, Cursor 2 scrolling bars at the top of 
the window. The red line is the Trigger position and cannot be 
moved across the captured waveforms.

Playback 
Rate

The number of samples shown every second. Can be increased/
decreased in order to improve the resolution of the playback. The 
default is 1 sample. The larger the value, the faster the cursor 
travels across the signal.

green Displays the parameter value at the green cursor 1 position.
When in Start mode, displays the time offset from the start time of 
the COMTRADE file.
When in Trigger mode, displays the amount of time from the trigger 
position (red line).

blue Displays the parameter value at the blue cursor 2 position.
When in Start mode, displays the time offset from the start time of 
the COMTRADE file.
When in Trigger mode, displays the amount of time from the trigger 
position (red line).

yellow Displays the difference between the green and blue parameter 
values. The box shows the difference in time (milliseconds).

Start Displays cursor times as an offset from the "Start Time" of the 
COMTRADE file. These times are always a positive value.

Trigger Displays cursor times as an offset from the "Trigger Time" of the 
COMTRADE file. A negative time indicates a time that occurs before 
the trigger and a positive time indicates a time that occurs after the 
trigger.

Actual Displays cursor times as an actual time stamp. The format for the 
time stamp is "mm/dd/yy HH:mm:ss.ssssss" and the hours are 
based on a 24 hour system.
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EnerVista Viewpoint Monitoring

Chapter 12: Administration

Administration

This chapter outlines passwords, users, and groups. See the Quickstart Guide and the 
Device Setup chapter for device management.
This chapter outlines the following:
• Default passwords
• Password rules
• Administrator user account and group
• Guest user account and group
• Turn login on and off
• Manage password
• Lost password
• Manage user accounts
• Manager user groups
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Introduction
Administration is performed in several windows in Viewpoint Monitoring.
By default, no login or password are required to open and use Viewpoint Monitoring, 
there are Administrator and Guest user accounts, and there are three user groups.
Upon installation of Viewpoint Monitoring, the change-password window appears 
repeatedly when accessing some functions as long as the Administrator password 
remains at the default of "password".
Permissions to various functions in Viewpoint Monitoring first are set on a group level, 
then on an individual basis as a subset of the group permissions.

Figure 176: Default user and group management view
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Default passwords
The default passwords are as follows:
• Administrator — password
• Guest — Guest
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Password rules
Passwords are case-sensitive. No other rules are enforced.
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Administrator user account and group
An Administrator user group and an Administrator user account are added by default. 
The account and group cannot be deleted or renamed. Only one administrator 
account is allowed.
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Guest user account and group
A Guest user group and a Guest user account are added by default. Their permissions 
cannot be changed. The account and group cannot be deleted.
The Guest user account becomes active when you set Viewpoint Monitoring to require 
login. There is also a separate access mode with limited functions, as outlined here.
To turn Guest use on or off:

1. In the main window of Viewpoint Monitoring, click File > Preferences. The 
window opens.

2. Set the security to FULL or Enhanced.
FULL — Users must log in at startup, for example with the Guest user account.
Enhanced — Users receive limited privileges at startup, without login. Access is 
granted to the IED Dashboard, Waveforms, and viewing in One-Line Viewer, 
Annunciator, Events, and Trending Reports. A user can then log in to receive 
additional permissions assigned to their user account, such as full access to the 
One-Line Editor or Annunciator.

3. Click the Ok button to save and exit. Note that you also need to exit from the 
software on the system tray if the Watchdog function is active and keeping the 
software running.
To exit from Enhanced mode, click Tools > Administration > Login User and log 
in as Administrator, for example.

Figure 177: Active options when Enhanced access set in preferences

34

35
36

37
38

39

40
41
42
43
44
45
46
47
48
49
50
51
52
53

54



CHAPTER 12: ADMINISTRATION TURN LOGIN ON AND OFF

ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL 195

Turn login on and off
The requirement to enter a user name and password can be turned on and off and 
over-rides any authentication configuration in the user account setup. For example, if 
you enter a user name and password for a user account, the user is not required to log 
in unless ViewPoint Monitoring is configured to force login.
Configuration at the software level is done in the Security tab under File > 
Preferences. See the Security section on page 30.
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Manage password
By default, no password is required to open and use Viewpoint Monitoring. The 
software prompts for the Administrator password to be set before access to user 
account management is allowed. This window continues to appear as long as the 
Administrator password remains at the default of "password". You can simply re-enter 
this password to continue use without resetting the password, but the window re-
appears with next access.
The setting in the Security tab under File > Preferences determines if users are 
required to login, regardless of any passwords set.

Set password
To set the password immediately after installation:

1. In the main Viewpoint Monitoring window, click the Administration option. The 
Set Password window opens. A password appears in the Enter Old Password 
field even when one has not yet been set.
Otherwise, see the next section to access the window.

2. Enter the password in the two password fields. Passwords are case-sensitive and 
no other rules are enforced.

3. Add a question and answer to use when you forget or lose the password. 
Examples of questions are what make was your first car, what is your mother’s 
maiden name, and what is your favorite color.
The window shown here is the one that appears repeatedly as long as the 
Administrator password remains at the default.

Figure 178: Password window

4. Click the Change button. The password and security question are set, and the 
user management window opens.
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Change password
To change the set password:

1. In the main Viewpoint Monitoring window, click Tools > Administration > 
Change Password. The Change Password window opens.

2. Enter the existing password in the field. Other fields do not become active until the 
correct password is entered. When the fields do become active, the existing 
security question and answer display.

3. Enter the new password in the two new password fields. Passwords are case-
sensitive and no other rules are enforced.

4. Leave or change the question and answer to use when you forget or lose the 
password. Examples of questions are what make was your first car, what is your 
mother’s maiden name, and what is your favorite color.

5. Click the Change button. The password and security question are set, and the 
window closes.
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Lost password
The default passwords for the Administrator and Guest are "password".
For user accounts other than Guest, there is a Forget your password? button to click 
in the login window if you forget your password. This allows you to answer whatever 
security question was set for your user account, then displays the password.
If these methods do not work and you are locked out of the software, contact GE Grid 
Solutions technical support as outlined in the Quickstart section on page 3. There is a 
procedure to default the passwords.

Figure 179: Login window
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Manage user accounts
By default, there is an Administrator account that is included in an Administrator 
group. Neither can be deleted. Only one administrate account is allowed, and its name 
cannot be changed.
The three types of user accounts are described as follows:
• Administrator — All access
• User account — Specified permissions for viewing or modifying functions
• Guest — View-only. Cannot modify any functions or acknowledge any alarms. No 

permissions can be set for guests.
Upon installation, the software prompts for the Administrator password to be set 
before access to user account management is allowed. This window continues to 
appear as long as the Administrator password remains at the default of "password". 
You can simply re-enter this password to continue use without resetting the password, 
but the window re-appears with next access.
Permissions to various functions in Viewpoint Monitoring first are set on a group level, 
then on an individual basis as a subset of the group permissions. For example, if a 
group has permission to three of four functions, a user account in the group can have 
permission to three or fewer functions.
The setting in the Security tab under File > Preferences determines if users are 
required to log in, regardless of any passwords set at the user account level.

Add user account
To add a user account:

1. In the main window of Viewpoint Monitoring, click the Administration option or 
click Tools > Administration > User Management. The user management 
window opens.

2. Click and expand a group on the left side of the window, for example Operators. 
You cannot add a user to the Administrator or Guest groups.

3. Click the Add User button. The panel displays on the right side.
4. Configure the user account on the right side of the panel. For the permissions, all 

or a subset of the permissions granted at the group level can be granted. All four 
permission entries appear only when configured as such for the group.
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Figure 180: User account settings

One-Line Editor — Enable to allow access to the One-Line Editor in which to 
draw diagrams for control and monitoring of devices.
Annunciator — Enable to allow access to the Annunciator, to set and manage 
alarms and alerts.
Reports — Enable to allow access to the Trending Reports, to view and archive 
data.
Commands — Enable to allow the user to send commands to devices. For the 
N60 example shown as follows, the user can click the Reset button. (This view is 
accessed by clicking the Dashboard button on a device in the IED Dashboard.) 
When the user is not allowed to send commands, the button is inactive/disabled.
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Figure 181: Reset button command example

Name — The name of the user account, for example John Smith.
Email 1, 2, 3 — Optionally enter email address(es) for the user account. The 
address here has nothing to do with email addresses entered in the Annunciator 
for alarm notification. The email address(es) are for reference only.
Phone — Optionally enter a telephone number for the user.
Comments — Optionally enter information about the user, such as job function, 
location, employment status.
Login — Enter a user name for logging in to the user account. A random default is 
provided, such as User458923732, which can be overwritten.
Password — Enter a password for logging in to the user account, overwriting the 
default entered, which is "password".
Confirm Password — Re-enter the password.
Changes are saved in real-time when you click into another panel; you do not 
need to click the Ok button, which exits from the window.

5. Record the user name and password, and provide them to the user.
6. Check that the permissions granted to the user are consistent with the 

permissions granted at the group level. Group permission is required for user 
permission too.

7. When done working in the panel for all users and groups, click the Ok button to 
exit.

Update user account
To update a user account:

1. In the User Management window, select the user account.
2. Enter the changes on the right side of the panel. The Administrator or Guest 
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account name and permissions cannot be changed.
3. Click the OK button to exit.

Delete user account
To delete a user account:

1. In the User Management window, select the user account. Or select a group to 
delete all user accounts in the group and the group itself.

2. Click the Delete button. The button is inactive for the Administrator and Guest 
user accounts because they cannot be deleted.

3. Confirm the deletion. The user account(s) and/or group is deleted. This action 
cannot be reversed.

4. Click the OK button to exit.
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Manage user groups
Administrator and Guest groups are present by default.
Permissions to various functions in Viewpoint Monitoring first are set on a group level, 
then on an individual basis as a subset of the group permissions. For example, if a 
group has permission to three of four functions, a user in the group can have 
permission to three or fewer functions.

Add group
To add a group:

1. In the main window of Viewpoint Monitoring, click the Administration option or 
click Tools > Administration > User Management. The user management 
window opens.

2. Click the Add Group button. A group is added at the bottom of the list; subgroups 
cannot be added to existing groups.

3. Configure the group on the right side of the panel.
Name — The name of the user group, for example Technicians.
Comments — Optionally add information about the group, such as location or 
type of employee included in the group.
One-Line Editor — Enable to allow access to the One-Line Editor in which to 
draw diagrams for control and monitoring of devices.
Annunciator — Enable to allow access to the Annunciator, to set and manage 
alarms and alerts.
Reports — Enable to allow access to the Trending Reports, to view and archive 
data.
Commands — Enable to allow the user to send commands to devices, for 
example click a Reset button in the IED Dashboard of a device.
Changes are saved in real-time when you click into another panel; you do not 
need to click the Ok button, which exits from the window.

4. Add a user to the group by clicking the Add User button, and enter the 
information as outlined previously.

5. When done working in the panel for all users and groups, click the Ok button to 
exit.

Update group
To update a group:

1. In the User Management window, select the group.
2. Enter the changes on the right side of the panel.

The Administrator or Guest group name cannot be changed.
If you disable any permissions that apply to user accounts in the group, the user 
accounts are also affected. This can mean that some user accounts have no 
permissions assigned to them, for example you disable the One-Line Editor 
permission and a user with access to only that one function no longer has 
permissions assigned to them.

3. Click the OK button to exit.
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Delete group
To delete a group:

1. In the User Management window, select the group.
2. Click the Delete button. The button is inactive for the Administrator and Guest 

groups because they cannot be deleted.
3. Confirm the deletion. The user accounts and group are deleted. This action 

cannot be reversed.
4. Click the OK button to exit.
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Chapter 13: Remote computers

Remote computers

This chapter outlines how to add computers for remote access of Viewpoint 
Monitoring.
• Set up Viewpoint Monitoring for remote access
• Install remote access client software on a computer
• Access Viewpoint Monitoring remotely
• Uninstall remote access client software
• Set time-out
• Remote computer interface
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Introduction
Remote viewer capability to a EnerVista Viewpoint Monitoring instance is optionally 
available through EnerVista Viewpoint Monitoring ViewNodes (requires separate 
EnerVista Viewpoint ViewNodes license) or Windows Server Remote Desktop 
Services connection (requires Windows Server option for Viewpoint Monitoring and 
Windows Remote Desktop Services (RDS) license from Microsoft). 

EnerVista Viewpoint Monitoring ViewNodes
EnerVista Viewpoint Monitoring ViewNode client software is installed on remote 
Windows non-server workstations to remotely connect to the workstation running the 
EnerVista Viewpoint Monitoring instance. For remote access there are no additional 
licensing requirements for the EnerVista Viewpoint Monitoring instance, however, a 
EnerVista Viewpoint Monitoring ViewNodes license is required for each remote 
workstation client. 
Up to 10 concurrent EnerVista Viewpoint Monitoring ViewNode clients can access a 
EnerVista Viewpoint Monitoring instance. Support for the remote access is configured 
in the Viewpoint Monitoring instance and then the ViewNode client software is installed 
and configured on the remote workstation to remotely access.

Windows server remote desktop services connection
With a Windows Server 2019/2022 installation, up to five computers can access the 
server connecting using Remote Desktop Services (RDS). One access can be the 
administrator and the others are users. 
This installation requires both the Viewpoint Monitoring License with Windows Server 
option as well as Windows Server 2019/2022 Remote Desktop Services (5-pack of 
Windows Server 2019/2022 Remote Desktop Services (per User, or per Device)).
No extra software installation is required on the remote workstation as the connection 
is through Windows Remote Desktop Services. Remote workstations with EnerVista 
Viewpoint Monitoring ViewNodes will not be able to connect to Viewpoint Monitoring 
Windows Server Installations using a ViewNodes remote connection as remote 
access is only provided using Windows Remote Desktop Services.

Trial version
For evaluation purposes, a trial version of EnerVista Viewpoint Monitoring ViewNode 
software is available for download from the GE Vernova Grid Solutions website. 
The trial version will operate for 15 days from installation before requiring a license.
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Set up Viewpoint Monitoring for remote access
This section applies to ViewNode remote access, not when using Remote Desktop 
Connection.
Viewpoint Monitoring supports multiple ViewNodes remotely connecting to it and 
viewing its published One-Line diagrams, Annunciator panels, Trending Reports, 
Waveforms, and Events. Up to 10 ViewNodes can connect concurrently to a Viewpoint 
Monitoring system.
Communication between Viewpoint Monitoring and ViewNodes is HTTP-based. The 
default HTTP port 80 is used. If you have trouble with any procedures outlined here, 
consult your system administrator to have your Viewpoint Monitoring system 
accessible from the Internet.
The ViewNode software needs to be installed on the remote computer. The ViewNode 
software can be downloaded from the Internet. No additional licensing is required to 
use the ViewNode client software.
ViewNode Support on the Viewpoint Monitoring computer requires Microsoft .NET 
Framework 4.0. This is because the XML-DA web service is a Microsoft .NET 4.0 
based web application. If .NET Framework 4.0 is not present, it is installed when 
Viewpoint Monitoring installs.
You configure support for the service in Viewpoint Monitoring, then install the 
ViewNode client software on a remote computer.

Software requirements for Viewpoint Monitoring
Microsoft Internet Services Manager (IIS) is required to use remote ViewNode 
workstations. It needs to be installed on the host computer only, meaning the 
computer with Viewpoint Monitoring already installed.
To check if Internet Services Manager (IIS) is installed:

1. On the computer with Viewpoint Monitoring installed, click Start > Control Panel 
and open the Programs and Features. The window opens.

2. Click the Turn Windows features on or off option on the left side. At the prompt, 
allow the program to make changes to the computer. A window opens.

3. Check if the Internet Information Services check box is colored or enabled. 
(See the following figure.) A colored box without a check mark indicates that the 
function is selected and some but not all features selected; this is okay.
If IIS is active, expand the entry, then the World Wide Web Services folder, then 
the Application Development Features folder, and check if ASP.NET is 
installed.
If no (both IIS and ASP.NET are not installed), install them as outlined in the next 
procedure.

To install Internet Services Manager (IIS):

1. Close Viewpoint Monitoring.
2. In the Programs and Features window outlined, click the Turn Windows features 

on or off option on the left side. At the prompt, allow the program to make 
changes to the computer. A window opens.

3. Expand the Internet Information Services entry.
4. Expand the World Wide Web Services entry.
5. Enable the Internet Information Services and ASP.NET options. Leave the 

other default selections as is. A colored box without a check mark indicates that 
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the function is selected and some but not all features selected; this is okay.
6. Click the OK button to install, and restart the computer at the prompt. Internet 

Information Services installs. Continue with the next section to configure 
Viewpoint Monitoring in the wizard.

Figure 182: Installing Internet Information Services

Set up and configure ViewNode support
To configure Viewpoint Monitoring for ViewNode remote access:

1. In the main window of Viewpoint Monitoring, click File > ViewNode Management 
> Setup ViewNode Support.
If you are logged in to the software without administrator rights, as message 
appears that you need to be logged in to the computer with administrator rights. 
Exit from Viewpoint Monitoring, right-click its icon on the desktop, select the Run 
as administrator option, and accept access at the prompt.
With successful launch, a wizard opens.

2. Viewpoint Monitoring checks if all needed software is installed and prompts when 
not, as follows.
First, it checks if Internet Information Services (IIS) has been installed. If not, the 
wizard explains how and does not let you continue (see the following figure). Exit, 
install IIS as outlined in the previous section, and try again.
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Figure 183: Prompt to install Microsoft Internet Information Services (IIS)

Second, Viewpoint Monitoring checks that Microsoft .NET Framework is installed. 
If not, the Install .NET Framework window opens. Click the button to install .NET.
Third, Viewpoint Monitoring checks that required web applications are installed. If 
not, the Install Viewpoint Web Applications window opens. Click the button to 
install them.

Figure 184: Prompt to install related web components

If installation does not work at this point, contact GE technical support.



210 ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL

SET UP VIEWPOINT MONITORING FOR REMOTE ACCESS CHAPTER 13: REMOTE COMPUTERS

3. With all components installed, click the Next button in the wizard. The Publishing 
window opens. Or after initial setup, to access the window manually for 
configuration, click File > ViewNode Management > Configure ViewNode 
Support.

4. Complete the fields.
Site Name — The computer or site name for the Viewpoint Monitoring installation. 
This is used for the remote computer to know which Viewpoint Monitoring 
installation they are connecting to. In the example shown, the name of the 
Viewpoint Monitoring installation is "VPM_Server1." 
When you change the name here, it also changes in File > Preferences > Host 
Information.
Waveforms — Enable to allow waveform/oscillography diagrams to be published 
to and viewable by the remote ViewNode computers.
Events — Enable to allow event records to be published to and viewable by the 
remote ViewNode computers.
Reports — Enable to allow trending reports to be published to and viewable by 
the remote ViewNode computers.
Publishing Single Line Diagrams — Click the Add button to enable specific 
One-Line Editor diagrams to be made available to the remote ViewNode 
computers. You can choose not to publish any diagrams at this time and do 
configuration later. These are .sf files.
Publishing Annunciator Panels — Click the Add button to enable specific alarm 
panels created in the Annunciator function to be made available to the remote 
ViewNode computers. You can choose not to publish any annunciator panels at 
this time and do configuration later. These are .ap files.

Figure 185: ViewNode support configuration window

If using the wizard, click the Next button to continue. Otherwise, click the Access 
Control tab.
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5. The Access Control window/tab displays all ViewNodes currently connected to 
your system in the ViewNode Access Information table. You can also enable the 
Deny Access from all ViewNodes check box to deny access. At initial setup of 
ViewNodes, there are none connected to your system, and access is denied. 
Disable the check box to allow access.

Figure 186:  Access Control tab displays remote computers connected

6. Click the Finish or OK button. Your Viewpoint Monitoring system is able now to 
support up to 10 ViewNodes concurrently to remotely connect to your system and 
view any published One-Line diagrams, alarm panels, trending reports, 
waveforms, and events.

Remove remote access
If the ViewNode Support is set up and you no longer need it in your Viewpoint 
Monitoring system, you can discontinue it, which unregisters the components that are 
used for ViewNode support. The service can be re-instated.
To remove remote service:

1. In Viewpoint Monitoring, click File > ViewNode Management > Remove 
ViewNode Support. The ViewNode Support service unregisters and no remote 
ViewNode computers can connect to the Viewpoint Monitoring system; a call from 
a ViewNode fails after that.
To reinstall the service, use the Setup ViewNode Support menu option.
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Install remote access client software
This section describes the installion of ViewNodes client software for remote access.
The ViewNodes software needs to be installed on each workstation that is to access
Viewpoint Monitoring remotely and a license is required for activation. 
The software is available from the GE Vernova website at:  https://
www.gevernova.com/grid-solutions/automation/substation-solutions/software-tools/
enervista-viewpoint-monitoring
The ViewNodes client software cannot be installed on the same computer as the 
Viewpoint Monitoring system

Software requirements for remote computer
The ViewNode client software can be installed on computers running the following 
operating system:
• Windows 10, 11 (64 bit)
The ViewNode client software needs to be the same as the Viewpoint Monitoring 
installation being accessed. For example, ViewNode 8.0 works with Viewpoint 
Monitoring 8.0, but not with 7.2.
The remote computer also requires Microsoft SQL Server 2019/2022 Express. The 
installation wizard prompts automatically to install it when not found on the computer. 

Install client software
To install the ViewNodes remote access client software:

1. If the computer has pending Windows or Microsoft updates that require restart, 
restart the computer now.

2. Once logged in again, locate and click or double-click the ViewNodes Installation 
file, for example by placing it on the computer desktop. Allow changes to the 
computer at the prompt. The wizard opens.

3. When the computer does not have Microsoft SQL Server 2019/2022 Express 
installed, the system prompts to install it. Click the Install button to do so, then 
confirm at the prompt. The software installs.
If installing on a 32-bit computer and a message appears that installation appears 
to have failed, continue with the installation, then contact GE technical support. 
You can have a failed Microsoft SQL Server 2019/2022 installation and a 
successful ViewNode installation, but the latter does not function properly until the 
Microsoft SQL Server installation is fixed. The Microsoft SQL Server 2019/2022 is 
not supported on a Windows 10 32-bit computer. In this case you can manually 
install the Microsoft SQL Server 2012 Express SP1. Please contact the Customer 
support for this.
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Figure 187: Prompt to install Microsoft SQL Server Express on remote computer

4. When the ViewNode wizard opens, complete it to install the software. The default 
location is C:\Program Files (x86)\EnerVista\Viewpoint Monitoring\ViewNode. An 
icon is added to the desktop, and a menu item added in the location specified.

Figure 188: ViewNode installation wizard
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Access Viewpoint Monitoring remotely
The following two options can be used to access the software remotely:
• Remote Desktop Connection when you have a Windows Server 2019 installation
• With Viewpoint Monitoring ViewNode

Access remotely with Remote Desktop Connection
When Viewpoint Monitoring is installed on a Windows Server 2019/2022 computer, 
Remote Desktop Connection can be used to access Viewpoint Monitoring. Because 
Remote Desktop Connection normally is installed with Windows, no extra installation 
is required. The remote access is also referred to as Remote Desktop Services.
You run the service over the Internet with Remote Desktop Connection. Five 
concurrent connections to Viewpoint Monitoring are available, one being an 
Administrator and others being Guest accounts that can be logged in instead as user 
accounts. Since multiple users can run Viewpoint Monitoring, to avoid concurrency 
conflicts, adhere to the following rules:
• One master instance of Viewpoint Monitoring on the Windows Server 2019/2022 

computer
• Administrator access can be local or remote
• When Administrator access is in use, the login window switches automatically to 

Guest login
• When a Guest requires Administrator access, the Administrator must log out
• The Administrator has full control, regardless of local or remote access
• A Guest has limited control as follows:

– Administration including Preferences and License Management are not 
available

– ViewNode support management is not available
– Custom File Editor and Formula Editor are not available
– Device Setup is not available
– Watchdog Service cannot be configured
– Reports are available in view mode only
– Events and Waveforms are available in view mode only
– One-Line Editor and Viewer as well as Annunciator can be configured and 

viewed
• Before logging out from Remote Desktop Connection, exit Viewpoint Monitoring 

because logging out from Remote Desktop Connection does not free the 
application instance

• Quit the application only by clicking the Exit button. If Viewpoint Monitoring is 
exited using the Task Manager, this does not free the application instance. 
Eventually users run out of the four available concurrent connections. The only 
way to restore four available connections is by restarting the server.

To use Remote Desktop Connection, you need to know the full name or IP address of 
the remote computer and it needs to be configured to allow access. The Full 
computer name displays in the Control Panel in the System panel. An example is 
T123.server1.yourcompany.com
To allow a remote desktop connection:

1. Click Start, then right-click Computer and select Properties. Click the Remote 
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Settings option.
2. Enable the Allow connections from... option and apply.
To make a remote desktop connection:

1. Click Start > All Programs > Accessories > Remote Desktop Connection. The 
window opens.

2. Enter the full computer name of the remote computer, for example 
john.yourcompany.com. Or enter the IP address.

3. Click the Connect button.

Figure 189: Connecting to a remote computer

4. Log in at the prompt, where the user name and password are for the remote 
computer being accessed, not for Viewpoint Monitoring.

5. Once logged in to the computer, launch Viewpoint Monitoring and log in as 
Administrator, Guest, or with a user account.

Access remotely with ViewNode
Viewpoint Monitoring ViewNode is installed on a remote workstation to remotely 
connect to the Viewpoint Monitoring instance and is used on a remote workstation to 
view One-Line diagrams, Trending Reports, Annunciator alarm panels, Waveforms, 
and/or Events.
Note: If configured and used, the User Definable P&P screens are only available on the 
Viewpoint Monitoring instance. Remote access through Viewpoint Monitoring ViewNode 
does not support User Definable P&P (Plug & Play) screens as the plug and play files for 
different devices type are not copied or dynamically(published) from Viewpoint Monitoring 
instance to the remote workstation with ViewNode installed.  

To connect remotely to Viewpoint Monitoring:

1. Click the Viewpoint Monitoring ViewNode icon on the desktop, or click Start > All 
Programs > EnerVista > Viewpoint Monitoring ViewNode. The Viewpoint 
Server Configuration window opens.

Figure 190: Launching the software
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2. If not already displayed, enter the IP address of the Viewpoint Monitoring 
computer, click the Discover button, or select the computer from the drop-down 
list. Then click the Test Communication button to verify access.

Figure 191: Enter the Viewpoint Monitoring computer information

Figure 192: Automatic discovery of Viewpoint Monitoring computers

If the Viewpoint Monitoring computer is not located automatically, then enter its IP 
Address in the box. When using a local area network with a gateway enter 
ipconfig in a command window to view the multiple IP addresses and use the 
one in the network (for example with DNS suffix specified). Otherwise, find the IP 
address at the ViewPoint Monitoring computer in the Host Information tab under 
File > Preferences.
After entering the IP address, click the Test Communication button to verify 
access.
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Figure 193: IP address of Viewpoint Monitoring in Preferences

A proxy server is a computer on your network that sits between your computer 
and the Internet, transferring information for web browsing. It is used for security, 
website blocking, caching, and to obscure IP addresses of senders. If you use 
one to access the Internet, you need to enter the information here. To view proxy 
server information, open the Control Panel in Windows, access the Internet 
Options function, click the Connections tab, then the LAN settings button. Or 
look in the same panel in the Internet Explorer web browser. Or contact your 
information technology (IT) department for the information to enter in the fields. 
Because the proxy server information is not always visible when scripts are used 
for computer settings, you can need to contact your IT department.
Click the Ok button when done.

3. If messages display that the device is not supported or the file cannot be located, 
it means that the ViewNode client software version is too old. Upgrade the 
ViewNode client software on the remote computer.

Figure 194: Errors when using old ViewNode client software

4. With successful launch of the Viewpoint Monitoring ViewNode application, the 
ViewNode login window displays. By default, ViewNode shows Guest as the login 
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user name. Log in as Guest or any valid login name created in the Viewpoint 
Monitoring system. When logging in as Guest, leave the password at the default; 
simply click the OK button to log in. The default Guest password is "Guest".

Figure 195: Logging in remotely

After clicking the OK button to log in, ViewNode contacts Viewpoint Monitoring to 
verify that a valid user login name and password have been entered. After 
receiving the response of successful login verification, ViewNode downloads all 
necessary settings from Viewpoint Monitoring and starts the main window. The 
ViewNode view differs from the Viewpoint Monitoring view. The window is 
explained at the end of the Interface chapter.

Figure 196: ViewNode main window

If you are unable to access files, the reasons can be as follows:
• No files have been identified for sharing, as outlined in the Set up and configure 

ViewNode support section on page 208

• Files were saved with an absolute path, such as C:\MyFiles\MyG60File.sf. The 
files need to be saved with a relative path, such as MyG0File.
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Uninstall remote access client software
See the Uninstall software section on page 227.
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Set time-out
This section applies to ViewNode remote access.
By default, a remote computer connection times out after 1740 minutes, or 29 hours. 
This period can be changed.
To change the time-out:

1. At the main Viewpoint Monitoring computer, click Start > Control Panel, then 
Administrative Tools, then Internet Informations Services (IIS) Manager.
Or click Start > Run and enter inetmgr in the Run window.

2. Expand the menu on the left side. Click the Application Pools entry, right-click 
the VPMPool entry that is for ASP.NET 4.0, and select Set Application Pool 
Defaults. The window opens.

3. Scroll to the Regular Time Interval option near the bottom of the window, set the 
time, and click OK to save and exit. Enter 0 to run the remote computers 
continuously without timing out.

Figure 197: Setting remote computer time-out

The connection between the ViewNode and Viewpoint Monitoring usually is not 
indefinite. If an error is detected polling data for a single line diagram or annunciator, 
the ViewNode disconnects and a message displays to inform the user that the 
ViewNode needs to be restarted. The message reads "Communication error with 
Viewpoint Monitoring server was detected. Please restart Viewpoint node."
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Remote computer interface
This section applies to ViewNode remote access.
Remote computers accessing Viewpoint Monitoring with the client software are 
referred to as ViewNodes. The ViewNode interface differs from the Viewpoint 
Monitoring interface and is explained here. Functions accessible depend on 
permissions.
When ViewNode starts, a portion of report data, meaning the current hour, is 
synchronized immediately. The rest of the historical data is downloaded gradually. 
Data is downloaded backward for the period defined in the preferences, but not 
greater than 180 days. The speed of download depends on a number of parameters. 
For 500 parameters in all reports, a block of data of one-hour length is downloaded 
every 30 seconds. The period for download is readjusted dynamically, if the number of 
parameters changes. For example, for 50 parameters, a block of data of 10 hours 
length is downloaded every 30 seconds.

Figure 198: ViewNode main window

IED Dashboard — View online information of configured devices.
Server Setup — Set the Viewpoint Monitoring system to connect to on next ViewNode 
startup.
One-Line Viewer — View published One-Line diagrams. The One-Line diagrams 
need to be specified for remote viewing and are referred to as published, as 
configured under File > ViewNode Management > Configure ViewNode Support.
Annunciator — View published Annunciator alarm/alert panels. The panels need to 
be specified for remote viewing and are referred to as published, as configured under 
File > ViewNode Management > Configure ViewNode Support.
Events — View event records collected. Events are downloaded and updated 
dynamically in a local ViewNode database. The function needs to be enabled for 
remote viewing, as configured under File > ViewNode Management > Configure 
ViewNode Support.
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Reports — View trending reports configured. Reports are downloaded and 
synchronized dynamically in a local ViewNode database. The function needs to be 
enabled for remote viewing, as configured under File > ViewNode Management > 
Configure ViewNode Support. For the Reports function, the Communication Status 
legend in a ViewNode is labeled Communicating and differs from the ViewPoint 
Monitoring server in that it has two states, as follows:
• Connected — When reports are updated dynamically
• Blank — Means that reports are not updated dynamically because they are not 

running on the Viewpoint Monitoring computer because of a communication error 
between the server and the ViewNode or because of another other reason

COMTRADE — View waveforms collected. The function needs to be enabled for 
remote viewing, as configured under File > ViewNode Management > Configure 
ViewNode Support.
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Maintenance

This chapter outlines maintenance of the software.
• View software version
• View and manage software license
• Update software
• Manage activation code
• Transfer software license
• Uninstall software
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View software version
To view the version number of Viewpoint Monitoring:

1. Click Help > About EnerVista Viewpoint... The window opens.
2. View the number in the Version field.
3. Click the window to exit.
The Events window is a separate application.
To view the version number of the Event viewer:

1. In the main window of Viewpoint Monitoring, click the Events option. The window 
opens.

2. Click the About icon on the toolbar or click Help > About Event/Alarm Viewer. 
The window opens.

3. View the number in the Version field.
4. Click the window to exit.

View and manage software license
After installation, the software license is viewable from a folder on the computer. The 
number of licenses purchased can be viewed.
To view the software license on computer:

1. Navigate to the ViewNode folder, for example 
C:\Program Files (x86)\Enervista\Viewpoint Monitoring ViewNode
or
C:\Program Files\EnerVista\EnerVista Viewpoint Monitoring
The license is available as .pdf and .txt files, for example Software_License.pdf.

To view number of software licenses purchased:

1. Log in to 
https://apps-ex.gs.ec.ge.com/swmgr/ 
using the Order # and Password provided with the software or sent by email 
upon purchase.
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Update software
The software can be upgraded for new features and fixes. When purchased with the 
optional upgrade package, the updates are free for one year.
The Viewpoint Monitoring license also can be upgraded to add new Viewpoint 
Monitoring installations and/or options (purchase required) by entering a new 
activation code.
To check for updates:

1. In the main window of Viewpoint Monitoring, click Help > EnerVista Viewpoint 
on the Web > Home Page. A web browser and the EnerVista web page open.

2. Click the Software option.
3. Download any updated version specific to your release.
After initial activation, if the license manager detects any license options still available 
for upgrade, the license upgrade section is enabled in the license management 
window.
If your license code generated has the "OPC Option," the unlock operation needs to 
be done with Viewpoint Monitoring run "As Administrator" because the program 
changes all user settings of the servers, an activity similar to installing the application.
When updating the license, if the application is unlocked and you upgrade to a larger 
number of devices or add the "OPC option," first do a license transfer (for example, 
use the Site ID). This removes the previous license, restarts the program, and you 
enter the new license code.

Manage activation code
A valid software license is required, which is managed using an activation code. See 
the Quickstart Guide to add the activation code and unlock the software.
When updating the license, if the application is unlocked and you upgrade to a larger 
number of devices or add the "OPC option," first do a license transfer (for example, 
use the Site ID). This removes the previous license, restarts the program, and you 
enter the new license code.
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Transfer software license
A license/activation code does not allow installation on more than one computer, but 
you can move the software license from one installation to another. You cannot move 
a complete installation with its database to another computer, only the license.
You install Viewpoint Monitoring at the new computer, look up its Site ID, then transfer 
the license at the old Viewpoint Monitoring computer.
Also transfer the license when upgrading to a larger number of devices or adding the 
"OPC option." This removes the previous license, restarts the program, and you enter 
the new license code.
To view the Site ID:

1. In the new installation of the Viewpoint Monitoring computer, click Help > License 
Management. The window opens.

2. Record the Site ID.
To transfer the license:

1. On the old computer, open Viewpoint Monitoring and click Help > License 
Management. The window opens.

2. Enter the site ID in the New Site ID field, then click the Transfer button. You 
cannot transfer the license for a trial version of the software. With successful 
transfer, the license on the old installation is disabled, and the license on the new 
installation is enabled.

3. Click the Ok button to exit.

Figure 199: Transfer software license
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Uninstall software
If required, the Viewpoint Monitoring and/or the ViewNode client software can be 
uninstalled.
Uninstalling Viewpoint Monitoring also deletes configuration information. It does not 
delete some files, such as error logs, system logs, and configuration records, which 
are created after the Viewpoint Monitoring installation completes. Since these files are 
not part of the initial installation, they are not removed by the uninstaller and must be 
deleted manually. The SQL Express database remains.
If you have the "ViewNode Support" set up in your Viewpoint Monitoring system and 
have any ViewNodes remotely connected to your system, you must remove the 
"ViewNode Support" service first within Viewpoint Monitoring, as outlined here.

Uninstall Viewpoint Monitoring
To uninstall the Viewpoint Monitoring software:

1. If you have ViewNode support running for remote computer access, stop it in 
Viewpoint Monitoring by clicking File > ViewNode Management > Remove 
ViewNode Support. The option is active when support is present and inactive 
when no support is present. When service stops, all remote computers lose 
access.

Figure 200: Stopping remote access

The Viewpoint Monitoring software can now be uninstalled.
2. In Windows, click Start > Control Panel.
3. Click Programs and Features.
4. Click EnerVista Viewpoint Monitoring.
5. Click Uninstall and confirm the deletion. The Viewpoint Monitoring software is 

deleted.
To uninstall the Microsoft .NET Framework and any Microsoft SQL Server Express 
that were installed/used by Viewpoint Monitoring, follow a similar approach. Do not 
uninstall these applications when they are being used by other software on your 
computer.

Uninstall ViewNode remote client
To uninstall the ViewNode client software:

1. At the remote computer, click Start > Control Panel.
2. Click Programs and Features.



228 ENERVISTA VIEWPOINT MONITORING – INSTRUCTION MANUAL

UNINSTALL SOFTWARE CHAPTER 14: MAINTENANCE

3. Click EnerVista Viewpoint Monitoring ViewNode.
4. Click Uninstall and confirm the deletion. The client software is deleted.
To uninstall the Microsoft .NET Framework and Microsoft SQL Server that was 
installed/used by the remote computer, follow a similar approach. Do not uninstall 
these applications when they are being used by other software on your computer.
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Appendix A: Miscellaneous

Appendices Miscellaneous

This chapter outlines the document revision history.
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Revision history
The tables outline the releases and revision history of this document.

Table 1: Revision history

Table 2: Major changes for latest version E5

Table 3: Major changes for latest version E4

Table 4: Major changes for previous version E3

1601 part number Software Release date
1601-0270-A1 5.7x 21 March 2013
1601-0270-B1 7.1x 1 August 2014
1601-0270-C1 7.2x 8 April 2015
1601-0270-D1 8.0x 30 June 2016
1601-0270-D2 8.0x 14 September 2016
1601-0270-E1 8.1x 5 July 2018
1601-0270-E2 8.1x 15 February 2020
1601-0270-E3 8.1x 15 January 2021
1601-0270-E4 8.1x 03 March 2023
1601-0270-E5 8.15 5 June 2025

Chapter Change
All Updates for instruction clarity
4 Added additional details for Plug & Play Dashboard - 8 Series ESA, MM300E
5 Added details for device Offline Mode functionality update

Chapter Change
1 Updates for v8.14 release (Operating systems, System requirements).
4 Clarified Remote Access via Window Server Windows Remote Desktop Services 

and Viewpoint ViewNodes.
2, 13 Clarified Trial Version descriptions for Viewpoint Monitoring and ViewNodes.
10 Clarifications made on running and exporting reports and charts.

Chapter Change
1 Quickstart guide merged into the Introduction.
3 Adobe Flash video help removed due to Flash no longer being supported.
13 Windows 10 64 bit and Windows Server 2019 are the operating systems 

supported from version 8.13 going forward. 
Microsoft SQL Server 2019 Express updated as the database supported.
Microsoft.Net Framework no longer installed because is part of the supported 
operating systems.


